Bug 315211 - Text mode network installer fails with DHCP and SELinux
Text mode network installer fails with DHCP and SELinux
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 06:36 EDT by Andrew Haley
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 16:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Haley 2007-10-02 06:36:56 EDT
Description of problem:

If you install F8t2 in text mode, you get a file that is hard linked from two
places:

[root@zorro ~]# ls -idl /etc/sysconfig/networking/profiles/default/resolv.conf
/etc/resolv.conf
18759492 -rw-r--r-- 2 root root 70 2007-10-01 18:35 /etc/resolv.conf
18759492 -rw-r--r-- 2 root root 70 2007-10-01 18:35
/etc/sysconfig/networking/profiles/default/resolv.conf

This causes an SELinux failure at boot time:

Oct  1 17:14:01 zorro restorecond: Will not restore a file with more than one
hard link (/etc/resolv.conf) Invalid argument

The effect of this is that DHCP configuration of /etc/resolv.conf fails, and you
can't access any DNS servers.

How reproducible:

Every time

Steps to Reproduce:

Install f8t2 and choose the text mode installer, and select DHCP.
  
The easiest way to fix this would be to copy resolv.conf from 
/etc/sysconfig/networking/profiles/default/ rather than hard-linking it.
Comment 1 Daniel Walsh 2007-10-02 09:38:53 EDT
Or use symbolic links.  But this also looks like system-config-network/or
anaconda is not creating the file with the  right context?  

Could be related to Bugzilla #311481
Comment 2 Andrew Haley 2007-10-02 09:49:37 EDT
You're right, it isn't creating the file with the right context: I had to set
the type of /etc/resolv.conf to net_conf_t.
Comment 3 Chris Lumens 2007-10-02 16:50:45 EDT
I have verified that the latest build of anaconda sets the context on
/etc/resolv.conf correctly under text mode installations.

Note You need to log in before you can comment on or make changes to this bug.