Bug 315491 - crystal-project crashes repoquery
crystal-project crashes repoquery
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
http://www.redhat.com/archives/fedora...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 11:30 EDT by Curtis Doty
Modified: 2008-06-03 07:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-03 07:09:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Curtis Doty 2007-10-02 11:30:59 EDT
$ repoquery -ql crystal-project
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 806, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 803, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 473, in runQuery
    print pkg.doQuery(oper)
UnicodeEncodeError: 'latin-1' codec can't encode character u'\uf003' in position
25663: ordinal not in range(256)

Not sure how Bug 239744 got closed.
Comment 1 Seth Vidal 2007-12-06 23:40:08 EST
Rock - looks like either crystal-project changed or we fixed repoquery in f7 and f8.

reopen if you see otherwise.
Comment 2 Curtis Doty 2007-12-07 10:48:28 EST
Problem still occurs here. Tested against last night's push on both f7 and f8 again.
Comment 3 Seth Vidal 2007-12-07 11:16:36 EST
what's your lang set to?
Comment 4 Curtis Doty 2007-12-07 11:23:22 EST
Aha!

$ LANG=C repoquery -ql crystal-project >/dev/null ; echo $?    
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 808, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 805, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 473, in runQuery
    print pkg.doQuery(oper)
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeEncodeError: 'ascii' codec can't encode character u'\uf003' in position
25663: ordinal not in range(128)
1

$ LANG=en_US repoquery -ql crystal-project >/dev/null ; echo $? 
Traceback (most recent call last):
  File "/usr/bin/repoquery", line 808, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 805, in main
    repoq.runQuery(regexs)
  File "/usr/bin/repoquery", line 473, in runQuery
    print pkg.doQuery(oper)
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeEncodeError: 'latin-1' codec can't encode character u'\uf003' in position
25663: ordinal not in range(256)
1

$ LANG=en_US.UTF-8 repoquery -ql crystal-project >/dev/null ; echo $?
0
Comment 5 Tim Lauridsen 2008-06-02 07:58:47 EDT
I could reproduce the error and i have fixed it upstream.

http://devel.linux.duke.edu/gitweb/?p=yum-utils.git;a=blob_plain;f=repoquery.py;hb=c49110c6819716526b1902075a2304bb34c9f40d

Note You need to log in before you can comment on or make changes to this bug.