Bug 31560 - up2date segfaults (in python)
up2date segfaults (in python)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-12 14:58 EST by Dan Kelley
Modified: 2015-01-07 18:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 20:11:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb output whilst running up2date (4.18 KB, text/plain)
2001-03-14 17:31 EST, Dan Kelley
no flags Details

  None (edit)
Description Dan Kelley 2001-03-12 14:58:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


When I run up2date it segfaults in python.  This is the case whether I run 
/usr/bin/up2date or /usr/sbin/up2date.

Frankly, it's not clear to me that I should have both of the above on the
system, but they result from my having both up2date and up2date-gnome
installed.  

My system is _NOT_ clean redhat 7.0 since I've upgraded gnome using the
ximian packages.  I also tried the Nautilus stuff, and decided I hated it,
and I _think_ I removed most of the nautilus RPMs.



I'd be happy to run any tests that are suggested.






Reproducible: Always
Steps to Reproduce:
1. type /usr/bin/up2date as root
2. or type /usr/sbin/up2date as root
3.
	

Actual Results:  It goes along for a while and then crashes, with a dialog
box stating that python has crashed.

Expected Results:  updating!

FYI, "rpm -qa | grep gnome" produces the following list:

gnome-objc-devel-1.0.2-9
up2date-gnome-2.1.7-1
xmms-gnome-1.2.4-0_helix_1
gnome-pim-devel-1.2.0-5_helix_3
gnome-core-devel-1.2.4-0_helix_2
gnome-utils-1.2.1-7_helix_1
rep-gtk-gnome-0.15-0_helix_2
gnome-audio-1.0.0-12
gnome-games-1.2.0-9
gnome-linuxconf-0.33-7
gnome-objc-1.0.2-9
rhn_register-gnome-1.0-7
pygnome-applet-1.0.53-4_helix_2
gnome-pim-1.2.0-5_helix_3
pygnome-1.0.53-4_helix_2
gnome-libs-1.2.11-0_helix_1
libgnomeprint6-0.20-8_helix_5
gnome-core-1.2.4-0_helix_2
gnome-media-1.2.0-7_helix_1
gnome-users-guide-1.2-2_helix_1
gnome-vfs-0.5-0_eazel_2
gnomeicu-0.94.1-0_helix_1
gnome-audio-extra-1.0.0-12
gnome-games-devel-1.2.0-9
switchdesk-gnome-3.6-1
openssh-askpass-gnome-2.3.0p1-4
pygnome-capplet-1.0.53-4_helix_2
libunicode-0.4.gnome-0_helix_1
gnome-applets-1.2.4-0_helix_1
pygnome-libglade-1.0.53-4_helix_2
libgnomeprint11-0.25-8_helix_1
gnome-print-0.25-8_helix_1
gnome-pilot-0.1.55-0_helix_1
gnome-libs-devel-1.2.11-0_helix_1
Comment 1 Ryan Hill 2001-03-13 15:25:10 EST
Same issue here: 7.0 Install with Ximian and later, Eazel installed.
The issue was first discovered after updating to up2date-2.1.7-1.alpha since I
needed proxy support for the update agent.

Always reproduceable.

Note: All of the -helix libraries in your output are from Ximian.

As a workaround, I ended up blowing out the whole install and starting clean. 
Have updated all available packages from the 7.0 vanilla, including the new
kernel up to 2.2.17-14.

Hesitant to re-install Ximian since it may break the agent again.
Comment 2 Preston Brown 2001-03-14 17:19:12 EST
I believe it is segfaulting somewhere inside the python RPM bindings. To find
out:

as root:

gdb /usr/bin/python
run /usr/sbin/up2date

<wait for crash>

bt <at gdb prompt>

<cut and paste output>
Comment 3 Dan Kelley 2001-03-14 17:31:39 EST
Created attachment 12668 [details]
gdb output whilst running up2date
Comment 4 Preston Brown 2001-03-14 18:36:20 EST
definitely an rpm issue.

does rpm --rebuilddb fix things for you?  If not, how about 

ftp://rawhide.redhat.com/pub/rawhide/i386/RedHat/RPMS/rpm-4.0.2-0.41.i386.rpm?
Comment 5 Dan Kelley 2001-03-14 19:05:18 EST
Rebuilding didn't help, but the new RPM did.  Thanks VERY much for the help!!
Comment 6 Ryan Hill 2001-03-14 20:11:03 EST
ditto on the thanks :)

installed Ximian after all the 7.0 update packages, problem didn't appear 
again - must of picked up the latest RPM build as part of the update process.

Ximian and Up2date are working fine now.
Comment 7 Jay Turner 2001-03-15 08:47:36 EST
Closing out this issue as it appears to be resolved with the new RPM.
Comment 8 Dan Kelley 2001-03-15 09:07:46 EST
Actually, ximian (helix-update) still fails for me, segfaulting.  This isn't a
strong complaint, really, since my main desire was to get up2date to function,
and it now does.

Naturally, one could regard the ball as being in Helix's court at the moment,
but I thought I'd continue this thread -- if that's OK -- since a lot of RedHat
users are probably like me, desirous of keeping more up-to-date with GNOME than
we can be using just RedHat as a supplier.
Comment 9 Jeff Johnson 2001-03-15 09:18:14 EST
Actually the segfault is in rpm-4.0 which ximian links against, not ximian code.
Look for an
update to ximian linked against rpm-4.0.2 Real Soon Now.
Comment 10 Dan Kelley 2001-03-19 15:46:33 EST
Gosh, I was stupid and I installed Nautilus, thinking it would be stable, or
safe, or at least not virulent.  That was a mistake.   After a very crude thrust
at it ("rpm -qa | grep nautilus" followed by a "rpm -e" for the list of files),
I got gmc back on my desktop, but up2date is broken again.

In case it's useful to anybody, below I've pasted what gdb gives on a (failed)
up2date attempt.  Mea culpa.

Program received signal SIGINT, Interrupt.
0x40393b97 in __poll (fds=0x808a760, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:63
63	../sysdeps/unix/sysv/linux/poll.c: No such file or directory.
(gdb) where
#0  0x40393b97 in __poll (fds=0x808a760, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:63
#1  0x401a0391 in g_main_poll () from /usr/lib/libglib-1.2.so.0
#2  0x4019fd24 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#3  0x401a00dc in g_main_run () from /usr/lib/libglib-1.2.so.0
#4  0x400b7043 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#5  0x804a294 in main ()
#6  0x402d6f31 in __libc_start_main (main=0x804a0ac <main>, argc=2, 
    ubp_av=0xbffff844, init=0x8049968 <_init>, fini=0x804d40c <_fini>, 
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffff83c)
    at ../sysdeps/generic/libc-start.c:129
(

Note You need to log in before you can comment on or make changes to this bug.