Bug 31566 - lvm root filesystem and reiserfs - lvm_blk_ioctl: unknown command
lvm root filesystem and reiserfs - lvm_blk_ioctl: unknown command
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-12 15:37 EST by Tim Clymo
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 15:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-03-12 15:37:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.20 i686)


Wolverine system with latest rawhide kernel (2.4.2.0.1.19).
LVM tools updated to beta5 from SRPM at people.redhat.com/laroche
Kernel built with LVM patches from above SRPM - also changed to have
builtin - not modular - support for raid1 and reiserfs (and turn off
reiserfs extensive checking). All other options as for
kernel-2.4.2.0.1.19-i686.config
Boot partition (23Mb) using ext2 on RAID-1 (md0) - needs LILO lba32 to
reach it
LVM - 1VG containing 1PV (8Gb RAID-1 partition md1) and 8 LVOL's
(containing /, /home, /opt, /usr, /usr/local, /var, /tmp and swap). / on
lvol1 is 64 extents (256Mb). All 7 lvol filesystems built with mkfs -t
reiserfs -v 2 (minor issue here - the man page says the default hash format
is r5, but these got built with tea even though I didn't specify any -h
option)
Ramdisk built using lvmcreate_initrd.

Problem is an error message from LVM - "lvm_blk_ioctl: unknown command"
when the root fs is mounted at boot. This may be something or it may be
nothing since the system seems to carry on and appears to work fine, but
perhaps somebody would be kind enough to confirm that it is safe to ignore
this message.

Just to confirm, this only happens with reiserfs - if / is built on an lvol
with ext2, it doesn't give this message


Reproducible: Always
Steps to Reproduce:
1. See description
2.
3.
	

/var/log/messages from boot with ext2 root:
Mar 12 20:20:48 tcpc kernel: LVM version 0.9.1_beta5  by Heinz Mauelshagen 
(20/02/2001)
Mar 12 20:20:48 tcpc kernel: lvm -- Driver successfully initialized
Mar 12 20:20:48 tcpc kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Mar 12 20:20:48 tcpc kernel: IP Protocols: ICMP, UDP, TCP, IGMP
Mar 12 20:20:48 tcpc kernel: IP: routing cache hash table of 2048 buckets,
16Kbytes
Mar 12 20:20:48 tcpc kernel: TCP: Hash tables configured (established 65536
bind 65536)
Mar 12 20:20:48 tcpc kernel: NET4: Unix domain sockets 1.0/SMP for Linux
NET4.0.Mar 12 20:20:48 tcpc kernel: VFS: Mounted root (ext2 filesystem).
Mar 12 20:20:48 tcpc kernel: VFS: Mounted root (ext2 filesystem) readonly.
Mar 12 20:20:49 tcpc kernel: change_root: old root has d_count=3
Mar 12 20:20:49 tcpc kernel: Trying to unmount old root ... okay
Mar 12 20:20:49 tcpc kernel: Freeing unused kernel memory: 236k freed

/var/log/messages from boot with reiserfs root:
Mar 12 07:30:17 tcpc kernel: LVM version 0.9.1_beta5  by Heinz Mauelshagen 
(20/02/2001)
Mar 12 07:30:17 tcpc kernel: lvm -- Driver successfully initialized
Mar 12 07:30:17 tcpc kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Mar 12 07:30:17 tcpc kernel: IP Protocols: ICMP, UDP, TCP, IGMP
Mar 12 07:30:17 tcpc kernel: IP: routing cache hash table of 2048 buckets,
16Kbytes
Mar 12 07:30:17 tcpc kernel: TCP: Hash tables configured (established 65536
bind 65536)
Mar 12 07:30:17 tcpc kernel: NET4: Unix domain sockets 1.0/SMP for Linux
NET4.0.Mar 12 07:30:17 tcpc kernel: VFS: Mounted root (ext2 filesystem).
Mar 12 07:30:17 tcpc kernel: lvm -- lvm_blk_ioctl: unknown command 21264
Mar 12 07:30:17 tcpc kernel: reiserfs: checking transaction log (device
3a:00) ...
Mar 12 07:30:17 tcpc kernel: Using tea hash to sort names
Mar 12 07:30:18 tcpc kernel: ReiserFS version 3.6.25
Mar 12 07:30:18 tcpc kernel: VFS: Mounted root (reiserfs filesystem)
readonly.
Mar 12 07:30:18 tcpc kernel: change_root: old root has d_count=3
Mar 12 07:30:18 tcpc kernel: Trying to unmount old root ... okay
Mar 12 07:30:18 tcpc kernel: Freeing unused kernel memory: 236k freed
Comment 1 Matt Wilson 2001-03-12 15:52:08 EST
the final release will not support LVM (it is not in supportable shape).
Comment 2 Tim Clymo 2001-03-12 16:30:12 EST
Will it continue to be in rawhide? Is it possible that it will be reintroduced
for RH7.2? (ie what does "not in supportable shape" mean, and what needs to
change for it to get to supportable shape). I have heard (although I don't know
this for a fact) that SuSE has pretty good support for LVM including installer,
so it can't be completely broken...
Comment 3 Arjan van de Ven 2001-03-12 16:34:17 EST
It means that it crashes too much, and that newer _and_ older versions are
incompatible with the LVM in the current kernel. Which means that it becomes
impossible to upgrade later on......
Comment 4 Need Real Name 2001-09-26 01:55:07 EDT
Now that lvm 1.0 is out (and lvm 1.0.1rc2 which afaik takes care of the
"backward compatibility" issue), will official lvm support be added to Redhat
7.1/7.2 anytime soon?

Thanks
Comment 5 Arjan van de Ven 2001-09-26 06:33:38 EDT
1.0 isn't an option due to the backward compatibility issues, and a "fixed"
version isn't officially released yet.

For 7.2 it's too late as we can't get enough beta-testing for such a big change;
for later versions we will certainly try to get it in; but a beta series is
needed to test such an important thing. (It holds your data, just like a
filesystem, so it needs lots of public testing)

Note You need to log in before you can comment on or make changes to this bug.