Bug 316071 - Starting ices: runuser: warning: cannot change directory to /dev/null: Not a directory
Starting ices: runuser: warning: cannot change directory to /dev/null: Not a ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ices (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 16:33 EDT by Martijn Ras
Modified: 2008-02-18 13:03 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 13:03:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martijn Ras 2007-10-02 16:33:32 EDT
Description of problem:
Starting the ices service generates a warning since /dev/null is set as the
home-directory of the ices user account (ices:x:499:499:IceS Shoutcast
source:/dev/null:/sbin/nologin).

Version-Release number of selected component (if applicable): ices-2.0.1-4.fc7

How reproducible: Always

Steps to Reproduce:
1. service ices start                                                          
                                                                               
                       

Actual results:
Starting ices: runuser: warning: cannot change directory to /dev/null: Not a
directory                                                                      
                                                      
-bash: /dev/null/.bash_profile: Not a directory                                
                                                                               
                                                   
                                                           [  OK  ]

Expected results:
  Starting ices:                                           [  OK  ]

Additional info:
I changed the home-directory to /tmp to get rid of the warning:
$ usermod --home /tmp ices

Note You need to log in before you can comment on or make changes to this bug.