Bug 316221 - Example build.xml references non-existent lib directory
Summary: Example build.xml references non-existent lib directory
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 4
Classification: JBoss
Component: doc-Getting_Started_Guide   
(Show other bugs)
Version: 4.2.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Isaac Rooskov
QA Contact: Joshua Wulf
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-02 21:42 UTC by Mike Clark
Modified: 2015-08-06 05:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 01:59:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Clark 2007-10-02 21:42:28 UTC
Found a problem building the jmsejb3 example with the "JBoss Enterprise
Application Platform 4.2.0.CP01 Getting Started Guide".  It appears that the
build.xml file has a bug (gettingstarted/jsfejb3/build.xml).  The directory
defined by the ${applib} property:

   <property name="applib" location="lib" />

doesn't exist.  This causes the a build error:

   Buildfile: build.xml

   compile:

   war:

   jb3jar:

   BUILD FAILED
   /home/miclark/Desktop/gettingstarted/jsfejb3/build.xml:72:
/home/miclark/Desktop/gettingstarted/jsfejb3/lib not found.

   Total time: 0 seconds

Due to the inclusion of this directory in the jb3jar target:

   <fileset dir="${applib}">
       <include name="*.jar" />
   </fileset>

This can be corrected by creating the lib directory (empty) or commenting out
the above lines.  The compiled code this seems to work just fine.   I believe
the same problem exists with the seamjb3 example
(gettingstarted/seamjb3/build.xml) as well.

Cheers,
Mike C.

Comment 1 Michael Hideo 2008-01-17 05:49:27 UTC
Mass Re-Assignment to Vinu for vetting. Investigate and migrate to JIRA if
necessary. 

Comment 2 Vinu S Renish 2008-02-08 07:25:50 UTC
Fixed.

Comment 4 Isaac Rooskov 2009-09-11 01:59:52 UTC
This bug has been marked as fixed in 2008 so closing this bug


Note You need to log in before you can comment on or make changes to this bug.