Bug 31628 - gcc miscompiles kicker (from kdebase) at -O3
Summary: gcc miscompiles kicker (from kdebase) at -O3
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 31850 31982 31984 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-13 09:48 UTC by Karsten Hopp
Modified: 2007-03-27 03:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 03:34:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karsten Hopp 2001-03-13 09:48:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.2.19pre10ext3 i686)


There seems to be a timeout. When I try to add a button to the panel
(kicker) and I'm not fast enough, the panel will restart even if I 
have not selected anything yet.
If I am fast enough and select an application, the panel restarts,
but the new button doesn't show up

Reproducible: Always
Steps to Reproduce:
1. install kdebase-2.1.9
2. restart X
3. try to add a button:   Menu - Configure Panel - Add - Button  (wait) a
few seconds
3a. try to add a button:   Menu - Configure Panel - Add - Button - Internet
- Netscape
	

Actual Results:  panel restarts, no new button

Expected Results:  new button with selected application

Comment 1 Bernhard Rosenkraenzer 2001-03-13 13:36:51 UTC
This happened after I switched over to compiling kdebase with -O3 as 
recommended by the KDE team. I've reverted to using -O2, it's working now.

Assigning to gcc so the optimization problem can be fixed, changing priority 
to low because we usually don't use -O3.


Comment 2 Bernhard Rosenkraenzer 2001-03-15 13:25:47 UTC
*** Bug 31850 has been marked as a duplicate of this bug. ***

Comment 3 Bernhard Rosenkraenzer 2001-03-16 16:48:01 UTC
*** Bug 31984 has been marked as a duplicate of this bug. ***

Comment 4 Bernhard Rosenkraenzer 2001-03-16 16:48:37 UTC
*** Bug 31982 has been marked as a duplicate of this bug. ***

Comment 5 Sammy 2001-03-19 20:36:43 UTC
I belive the panel crashing is due to non-functioning kbuildsycoca!

Comment 6 Jakub Jelinek 2001-03-22 15:44:13 UTC
Can you please provide me with rpms (including .src.rpm) which reproduce this?
I've just tried to rebuild kdebase with -O3 and cannot reproduce this (the
rest of KDE rpms have been installed from binary rpms).
Ideally if you could at least track it down to a specific binary/library which
if compiles with flags foo does exhibit the problem and if compiled with flags
bar it does not.

Comment 7 Peter H.S. 2001-03-23 03:34:42 UTC
The latest round of (KDE) updates (kdebase-2.1-10 etc) has solved the Kicker / 
panel problems for me (bug #31984 :Add > Applet..)



Comment 8 Karsten Hopp 2001-08-23 14:53:25 UTC
Verified that it works now



Note You need to log in before you can comment on or make changes to this bug.