Bug 31638 - Every second sym53c8xx driver does a lookup on the disk
Every second sym53c8xx driver does a lookup on the disk
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-13 10:01 EST by Wolfgang Leideck
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 15:23:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Leideck 2001-03-13 10:01:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


I have a pc with a sym53c8xx scsi controler.
Every second sym53c8xx activates the disk, which is very noisy. 
Here is the output of /var/log/messages:
Mar 13 16:54:01 faerith kernel: sym53c875-0-<6,0>: sync msgout: 1-3-1-c-10.
Mar 13 16:54:01 faerith kernel: sym53c875-0-<6,0>: sync msg in: 1-3-1-c-10.
Mar 13 16:54:01 faerith kernel: sym53c875-0-<6,0>: sync: per=12 scntl3=0x90
scntl4=0x0 ofs=16 fak=0 chg=0.
Mar 13 16:54:01 faerith kernel: sym53c875-0-<6,0>: sync msgout: 1-3-1-c-10.
Mar 13 16:54:01 faerith kernel: sym53c875-0-<6,0>: sync msg in: 1-3-1-c-10.
Mar 13 16:54:01 faerith kernel: sym53c875-0-<6,0>: sync: per=12 scntl3=0x90
scntl4=0x0 ofs=16 fak=0 chg=0.
Whats wrong here? Are sym53c8xx and ncr53c8xx the same or should i use
the ncr53c8xx driver?

Reproducible: Always
Steps to Reproduce:
1. Install wolverine on a pc with sym53c8xx scsi controler
2. Reboot the pc
3. After some minutes the driver wrotes every second in /var/log/messages
	

Actual Results:  see description

Expected Results:  That there are no regulary lookups on disk.
Comment 1 Bill Nottingham 2001-03-13 12:13:25 EST
Is magicdev running?
Comment 2 Wolfgang Leideck 2001-03-28 03:27:11 EST
Hello.
I have stpped magicdev and the regulary lookup on disk stopped.

Thanks
Wolfgang
Comment 3 Andy Wang 2001-04-26 02:32:21 EDT
I notice this bugzilla entry is resolved.  I am having the same problem with
Kernel 2.4.2-2 that shipped with Red Hat 7.1.  The sym53c8xx module constantly
prints out the following entries:
Apr 25 22:01:06 ganja kernel: sym53c876-1-<2,0>: sync msgout: 1-3-1-0-0.
Apr 25 22:01:06 ganja kernel: sym53c876-1-<2,0>: sync msg in: 1-3-1-1e-0.
Apr 25 22:01:06 ganja kernel: sym53c876-1-<2,0>: sync: per=0 scntl3=0x0
scntl4=0x0 ofs=0 fak=7 chg=0.

Stopping magicdev does indeed make the problem go away.  However, this does not
appear to be a good resolution.  magicdev is intended to be used by people is it
not?
This is happening on a system with a LSI Logic SYM22801 board (53c876 dual
channel).
Since this bugzilla entry was opened against 7.1, I figured I'd attach a note to
this one instead of opening a new entry.  If I should be using a new entry
please let me know.

Note You need to log in before you can comment on or make changes to this bug.