Bug 316961 - files in /var/lib/nfs hierarchy should be marked as noverify
files in /var/lib/nfs hierarchy should be marked as noverify
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Layton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 11:03 EDT by Jakub Hrozek
Modified: 2008-07-24 16:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0742
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2007-10-03 11:03:53 EDT
Description of problem:
In nfs-libs's spec, files in /var/lib/nfs hierarchy are not marked as 
noverify. Since these files are meant to change, it results in unnecessary 
gripes during rpm -V.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-80.EL4

How reproducible:
always

Steps to Reproduce:
1. rpm -V nfs-utils

  
Actual results:
messages like
S.5....TC c /var/lib/nfs/rmtab
........?   /var/lib/nfs/rpc_pipefs

Expected results:
clean output
Comment 1 Jeff Layton 2007-10-16 12:34:54 EDT
Do you have an example of the specfile changes that need to be made, or even
some documentation that explains how to tag things with %noverify? I'm having
trouble finding any.
Comment 2 Jakub Hrozek 2007-10-17 06:43:05 EDT
Sorry, the opening comment was really confusing..not actually %noverify (I 
don't think there is a such directive :) ), I was thinking along the lines 
of %verify(not md5 size mtime)..
Comment 3 Jeff Layton 2007-10-29 17:22:48 EDT
Test packages with these changes are available on my people page:

http://people.redhat.com/jlayton/

Please test them and report back whether this is fixed.
Comment 4 Jakub Hrozek 2007-11-01 14:05:57 EDT
Yes, this is fixed, I did verify with both specfile inspection (contains 
the %verify(not md5 size mtime)) and a simple testcase:

Old packages:
# echo "foobar" > /var/lib/nfs/rmtab
# rpm -V nfs-utils
S.5....T  c /var/lib/nfs/rmtab

New packages:
# echo "foobar" > /var/lib/nfs/rmtab
# rpm -V nfs-utils
#

Thank you!
Comment 6 Jeff Layton 2007-11-05 08:29:38 EST
Committed in 1.0.6-85.EL4
Comment 11 errata-xmlrpc 2008-07-24 16:00:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0742.html

Note You need to log in before you can comment on or make changes to this bug.