Bug 317461 - alsa-lib-devel-1.0.14-3.fc7 documentation file conflicts with x86_64 version
alsa-lib-devel-1.0.14-3.fc7 documentation file conflicts with x86_64 version
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-03 17:45 EDT by Michael Ploujnikov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 08:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from yum -y install alsa-lib-devel &> yum.log (40.54 KB, text/plain)
2007-10-03 17:45 EDT, Michael Ploujnikov
no flags Details

  None (edit)
Description Michael Ploujnikov 2007-10-03 17:45:17 EDT
Description of problem:
The installation (or upgrade) process of alsa-lib-devel.i386 fails on my system
which already has alsa-lib-devel - 1.0.14-3.fc7.x86_64 installed. The failure
seems to be a result of a conflict between some documentation files (see
attachment for a full list).

Version-Release number of selected component (if applicable):
alsa-lib-devel-1.0.14-3.fc7

How reproducible:
always

Steps to Reproduce:
1. yum -y install alsa-lib-devel
2.
3.
  
Actual results:
installation/upgrade of alsa-lib-devel fails due to file conflicts, eg:
"file /usr/share/doc/alsa-lib-devel-1.0.14/doxygen/html/version_8h-source.html
from install of alsa-lib-devel-1.0.14-3.fc7 conflicts with file from package
alsa-lib-devel-1.0.14-3.fc7"

Expected results:
installation/upgrade of alsa-lib-devel succeeds

Additional info:
$ rpm -qf /usr/share/doc/alsa-lib-devel-1.0.14/doxygen/html/version_8h-source.html
alsa-lib-devel-1.0.14-3.fc7
$ yum list alsa-lib-devel
Installed Packages
alsa-lib-devel.x86_64                    1.0.14-3.fc7           installed       
Available Packages
alsa-lib-devel.i386                      1.0.14-3.fc7           updates
Comment 1 Michael Ploujnikov 2007-10-03 17:45:17 EDT
Created attachment 215181 [details]
output from yum -y install alsa-lib-devel &> yum.log
Comment 2 Martin Stransky 2007-10-10 07:20:17 EDT
Works fine for me. A yum bug?

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 alsa-lib-devel          i386       1.0.14-3.fc7     updates           1.4 M
 alsa-lib-devel          x86_64     1.0.14-3.fc7     updates           1.4 M
 alsa-utils              x86_64     1.0.14-2.fc7     updates           1.0 M
Installing for dependencies:
 alsa-lib                x86_64     1.0.14-3.fc7     updates           410 k
 alsa-lib                i386       1.0.14-3.fc7     updates           409 k

Transaction Summary
=============================================================================
Install      5 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 4.6 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): alsa-lib-1.0.14-3. 100% |=========================| 409 kB    00:00     
(2/5): alsa-lib-1.0.14-3. 100% |=========================| 410 kB    00:00     
(3/5): alsa-lib-devel-1.0 100% |=========================| 1.4 MB    00:00     
(4/5): alsa-utils-1.0.14- 100% |=========================| 1.0 MB    00:00     
(5/5): alsa-lib-devel-1.0 100% |=========================| 1.4 MB    00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: alsa-lib                     ######################### [1/5] 
  Installing: alsa-lib                     ######################### [2/5] 
  Installing: alsa-lib-devel               ######################### [3/5] 
  Installing: alsa-utils                   ######################### [4/5] 
  Installing: alsa-lib-devel               ######################### [5/5] 

Installed: alsa-lib-devel.i386 0:1.0.14-3.fc7 alsa-lib-devel.x86_64
0:1.0.14-3.fc7 alsa-utils.x86_64 0:1.0.14-2.fc7
Dependency Installed: alsa-lib.x86_64 0:1.0.14-3.fc7 alsa-lib.i386 0:1.0.14-3.fc7
Comment 3 Michael Ploujnikov 2007-10-11 19:59:42 EDT
Well, removing the package with rpm helped:

# rpm -e --nodeps alsa-lib-devel
# yum install alsa-lib-devel
livna                     100% |=========================| 2.1 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package alsa-lib-devel.i386 0:1.0.14-3.fc7 set to be updated
---> Package alsa-lib-devel.x86_64 0:1.0.14-3.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 alsa-lib-devel          i386       1.0.14-3.fc7     updates           1.4 M
 alsa-lib-devel          x86_64     1.0.14-3.fc7     updates           1.4 M

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 2.8 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): alsa-lib-devel-1.0 100% |=========================| 1.4 MB    00:02     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: alsa-lib-devel               ######################### [1/2] 
  Installing: alsa-lib-devel               ######################### [2/2] 

Installed: alsa-lib-devel.i386 0:1.0.14-3.fc7 alsa-lib-devel.x86_64 0:1.0.14-3.fc7
Complete!

Note You need to log in before you can comment on or make changes to this bug.