Bug 31763 - commands in /etc/modules.conf do not restore mixer settings
Summary: commands in /etc/modules.conf do not restore mixer settings
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-14 05:36 UTC by Michal Jaegermann
Modified: 2014-03-17 02:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 05:36:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-03-14 05:36:21 UTC
'sndconfig', I presume, wrote the following in /etc/modules.conf:

alias sound-slot-0 es1371
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S

which is mostly correct but mixer settings are not restored when that
module is reloaded. This "post-install" line should be:

post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null
2>&1

and then it works.

  Michal
  michal@harddata.com

Comment 1 Bill Nottingham 2001-03-14 05:42:11 UTC
Yeah, this is fixed in sndconfig-0.64.4-1.


Note You need to log in before you can comment on or make changes to this bug.