Bug 317861 - [hts5.1.1][ia64-xen][audio][EL4-U6 & RHEL5.1] - Test Plan Varies for the same system
[hts5.1.1][ia64-xen][audio][EL4-U6 & RHEL5.1] - Test Plan Varies for the same...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 03:18 EDT by Satyabrata Maitra
Modified: 2008-07-16 18:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 12:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ia64-xen-RHEL5.1-test results - here Audio test not appeared in test plan (430.00 KB, application/x-tar)
2007-10-04 03:18 EDT, Satyabrata Maitra
no flags Details
ia64-xen-EL4-U6-test results - here Audio test appeared in test plan (660.00 KB, application/x-tar)
2007-10-04 03:22 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-10-04 03:18:47 EDT
Description of problem:
When testing hts-5.1.1 for EL4-U6 and RHEL5.1-server in the same ia64-xen
system, the test plan varies by hardware component - Audio.

If the hts picks up the test plan depending on the hardware set up in that
system where it is being tested, if I use the same system different time for
testing hts whth EL4-U6 and RHEL5.1-Server, it should generate the same test
plan each time, even if the OS is different. 

But for EL4-U6 its generating test plan for Audio where for RHEL5.1-Server, its
not doing that.

Is it a bug? If this is how hts picks up the test plan, it should be a bug, but
if not, then its not a bug! Please inform.

Both the test results,.log file, .rpm file, sysreport are attached with this bug
 in .tar file. Please see!
Version-Release number of selected component (if applicable):


How reproducible:
Performed once only.

Steps to Reproduce:
1. Pick up any ia64-xen system
2. First test hts5.1.1 with RHEL5.1-Server on this, atleast up to Test plan 
   stage
3. Collect the test plan for this.
4. Now use the same system for EL4-U6 to test hts-5.1.1.
5. Proceed atleast up to test plan generation stage.
6. Collect the Test plan for this.
7. compare the Test Plans for both the system
8. Observe, there is a plan for audio in EL4-U6, which is not present in RHEL5.1 
   one.

I think, to take this difference in test plan for audio, system must be some
audio output in use.

Actual results:
Generating different test plan the same system with different O.S


Expected results:
The Test Plan should be the same as the system is the same even if the O.S Differs.

Additional info:
Comment 1 Satyabrata Maitra 2007-10-04 03:18:47 EDT
Created attachment 215501 [details]
ia64-xen-RHEL5.1-test results - here Audio test not appeared in test plan
Comment 2 Satyabrata Maitra 2007-10-04 03:22:06 EDT
Created attachment 215511 [details]
ia64-xen-EL4-U6-test results - here Audio test appeared in test plan

For both the testing the tree followed as below :-
RHEL5.1-Server - tree-20070927.0
EL4-U6-AS - tree-20070927.0
hts version :- hts-5.1.1
arch :- ia64-xen
Comment 3 Greg Nichols 2007-10-04 09:54:02 EDT
Fixed in R4
Comment 4 Satyabrata Maitra 2007-10-10 02:30:47 EDT
Hi Greg

I checked in porkchop. the latest version of hts is showing 5.1-3 for both EL5
and EL4. 
http://porkchop.devel.redhat.com/brewroot/packages/hts/5.1/

May I know when R4 will be available in porkchop, please?
Thanks
Comment 5 Satyabrata Maitra 2007-10-16 08:51:53 EDT
I retested hts-5.1-4 for RHEL5.1-Server won ia64 system, but the same for
EL4-U6-AS not tested yet. Once it complete, I will compare and will put comment
on the basis of that! :) Hope it will be done tomorrow.

Note You need to log in before you can comment on or make changes to this bug.