Bug 317871 - [hts-5.1.1][i386][cdrom][EL4-U6] - cdrom testing giving traceback error
[hts-5.1.1][i386][cdrom][EL4-U6] - cdrom testing giving traceback error
Status: CLOSED DUPLICATE of bug 313501
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i386 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 03:35 EDT by Satyabrata Maitra
Modified: 2008-07-16 17:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 09:53:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
i386-cdrom-tar file (380.00 KB, application/x-tar)
2007-10-04 03:35 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-10-04 03:35:11 EDT
Description of problem:
When Tested hts-5.1.1 on EL4-U6 for i386 arch, its given Traceback Error!!
output.log, info files are attached with this bug as .tar file.

Version-Release number of selected component (if applicable):
hts-5.1.1
Tree used : EL4-U6-20070927.0

How reproducible:
Reproduced once with one try.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
It is giving traceback error

Expected results:
Its should PASS.

Additional info:
Comment 1 Satyabrata Maitra 2007-10-04 03:35:11 EDT
Created attachment 215521 [details]
i386-cdrom-tar file
Comment 2 Greg Nichols 2007-10-04 09:36:27 EDT
is dbus-python installed?  if so, this is a duplicate.

Here's the traceback, for easy reference:

Running ./cdrom.py:
lshal version 0.4.2
  block.device = '/dev/hdb'  (string)
Traceback (most recent call last):
  File "./cdrom.py", line 692, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./cdrom.py", line 550, in run
    features = self.configDeviceHAL(cdromDevice,cdromDeviceUDI)
  File "./cdrom.py", line 133, in configDeviceHAL
    cdromDevice = hal.getDevice(cdromUDI)
  File "/usr/share/hts/lib/hts/hal.py", line 29, in getDevice
    return Device(Constants.hal, self.getDeviceProperties(udi))
  File "/usr/share/hts/lib/hts/hal.py", line 39, in getDeviceProperties
    return self.__GetDevice(udi).GetAllProperties()
  File "/usr/share/hts/lib/hts/hal.py", line 32, in __GetDevice
    dev_obj=self.bus.get_object('org.freedesktop.Hal',udi)
AttributeError: SystemBus instance has no attribute 'get_object'
...finished running ./cdrom.py, exit code=1
Comment 3 Greg Nichols 2007-10-04 09:37:07 EDT
I meant, if it's NOT installed, this bug is a duplicate
Comment 4 Satyabrata Maitra 2007-10-08 03:13:47 EDT
I think, for EL4-U6, the client systems for archs i386 and x86_64 requires
dbus-python to generate the test plan for the hts. If, so, then, I think, the
system was dbus-python package installed, otherwise, it would not generate the
test plan even, following which I tested cdrom and other testing.
I can not confirm this, because, I used reserved system for this test.

But at the same time, when I read through the results.xml file output for cdrom
testing, i found the same traceback as you mentioned here in this bug. So, now,
please decide, whether its duplicate bug or a new one. :) Otherwise, I need to
retest once again to find out if the package installation status!
Comment 5 Greg Nichols 2007-10-08 09:53:58 EDT

*** This bug has been marked as a duplicate of 313501 ***

Note You need to log in before you can comment on or make changes to this bug.