Bug 31790 - Redirects after Submit to Network pages
Redirects after Submit to Network pages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Other (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eddie Chen
Web Development
http://www.redhat.com/apps/home/accou...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-14 13:11 EST by Martin C. Messer
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 15:47:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin C. Messer 2001-03-14 13:11:06 EST
After updating a user account, the Submit action delivers the user inside
the /network are of the site. Probably shouldn't do that unless they choose
to update their account from within /network.

To reproduce this problem, visit the My Account page:

http://www.redhat.com/apps/home/account.html

Login as a web user, click View/Update {anything}, and click Submit on the
form. You'll end up at:

http://www.redhat.com/network/prefs/account.html

The update occurs, but this is confusing to the customer.
Comment 1 Martin C. Messer 2001-03-14 13:12:56 EST
Jay, CC'ing you since this likely occurred due to a RHN change.
Comment 2 Eddie Chen 2001-03-21 16:20:51 EST
Fixed on my sandbox
http://echen.current.webdevel.redhat.com/apps/home/account.html

files affected
/apps/panes/header/nav/commerce.rdf
/apps/panes/user/callback.apm, user.apm
/apps/user/index.html

Jay please test.
Comment 3 Martin C. Messer 2001-03-21 16:28:43 EST
I get this:

Errors Output 

   1.[Wed Mar 21 16:54:35 2001] null: error executing code for include
     /var/sandbox/echen/current/apps/panes/login/callback.apm: [Wed Mar 21
16:54:35 2001] null: DBD::Oracle::db prepare
     failed: ORA-03113: end-of-file on communication channel (DBD ERROR:
OCIStmtExecute/Describe) at
     /var/www/lib/WebUser.pm line 153. [Wed Mar 21 16:54:35 2001] null: ;
compiled to SCALAR(0x9d61ee8) at
     /var/www/lib/Apache/ASP.pm line 3672. , /var/www/lib/Apache/ASP.pm line
1473 

Debug Output 

   1.[Wed Mar 21 16:54:35 2001] null: error executing code for include
     /var/sandbox/echen/current/apps/panes/login/callback.apm: [Wed Mar 21
16:54:35 2001] null: DBD::Oracle::db prepare
     failed: ORA-03113: end-of-file on communication channel (DBD ERROR:
OCIStmtExecute/Describe) at
     /var/www/lib/WebUser.pm line 153. [Wed Mar 21 16:54:35 2001] null: ;
compiled to SCALAR(0x9d61ee8) at
     /var/www/lib/Apache/ASP.pm line 3672. , /var/www/lib/Apache/ASP.pm line
1473 


ASP to Perl Script 

  1: package Apps; ;; sub Apps::NoCache {  ;;  @_ = (); ;; use strict;;use vars
qw($Application $Session $Response $Server $Request);;use lib
qw(/var/sandbox/echen/current/apps);;;
  2:   # Page to prompt for login.  Uses saved_url to return from
  3:   # whence we came..
  4:  
  5:   my $title;
  6: 
  7:   if ($Apps::Param->{'title'}) {
  8:      $title = $Apps::Param->{'title'};
  9:   }
 10:   $title ||= Apps::gettext("My Account");
 11: 
 12:   Apps::Pane::Display('header', 'title'=>$title);
 13: 
 14: if (Apps::User::Entry()) {
 15:    # Redirect back...
 16:    my $url = Apps::UrlStack::pop();
 17:    if ($url) {
 18:      $Response->Redirect($url->{URL});
 19:      $Response->Finish();
 20:    }
 21: } ; $main::Response->WriteRef(\('
 22: 
 23: 
 24: <table width="90%" border="0" cellspacing="0" cellpadding="0"
align="CENTER">
 25:    <tr>
 26:            <td>
 27:            <FONT FACE="HELVETICA">
 28:            ')); msg({  }, 'Your account gives you preferred access to
redhat.com. Whether purchasing cool stuff from our store, getting support, or
taking advantage of one of our special offerings, having an account makes it
easy for you to do it all.'); ; $main::Response->WriteRef(\('
 29:            
 30:            <br>&nbsp;
 31:            <br>
 32:            <p><FONT FACE="HELVETICA" SIZE="3"
COLOR="#666666"><B>Login</B><BR></FONT>
 33: <table width="100%" border="0" cellspacing="0" cellpadding="0"><tr><td><IMG
SRC="/img/pixel.gif" WIDTH="1" HEIGHT="4" ALT=""></td></tr><tr><td
bgcolor="#999999"><IMG SRC="/img/pixel.gif" WIDTH="1" HEIGHT="1"
ALT=""></td></tr></table></p>
 34: 
 35:            ')); msg({  }, 'If you have previously created an account with
Red Hat, enter your user name and password and click "Log In".'); ;
$main::Response->WriteRef(\('
 36:            <p>
 37:            ')); Apps::pane({  type=>"login"  }, ''); ;
$main::Response->WriteRef(\('
 38:    <br>
 39:            <br>
 40:            </font>
 41:            
 42:            <p>
 43:            <FONT FACE="HELVETICA">
 44:            <p><FONT FACE="HELVETICA" SIZE="3" COLOR="#666666"><B>Create a
New Account</B><BR></FONT><table width="100%" border="0" cellspacing="0"
cellpadding="0"><tr><td><IMG SRC="/img/pixel.gif" WIDTH="1" HEIGHT="4"
ALT=""></td></tr><tr><td bgcolor="#999999"><IMG SRC="/img/pixel.gif" WIDTH="1"
HEIGHT="1" ALT=""></td></tr></table></p>
 45:            ')); msg({  }, 'In one quick step, you\'ll set up a basic
profile for use in all your transactions on redhat.com.'); ;
$main::Response->WriteRef(\(' 
 46:            <p>
 47:            ')); msg({  }, 'Then, tell us how you want to be contacted.
It\'s our goal to respect your privacy and we\'ll use the information you
provided at your request. For more information, see our'); ;
$main::Response->WriteRef(\(' <a href="/legal/privacy_statement.html">'));
msg({  }, 'Privacy Statement'); ; $main::Response->WriteRef(\('</a>.
 48:            <p>
 49:            <a href="/apps/user/join/index.html"><b>')); msg({  }, 'New
Login'); ; $main::Response->WriteRef(\('</b></a>
 50:            </td>
 51:    </tr>
 52: </table>
 53: 
 54: <br><br>
 55: 
 56: ')); Apps::pane({  type=>"footer"  }, ''); ; $main::Response->WriteRef(\('
 57: </FONT>'));;;no lib qw(/var/sandbox/echen/current/apps); ;; }
Comment 4 Eddie Chen 2001-03-21 18:28:52 EST
There was an oracle problem, I can't reproduce it. Can you try again
Comment 5 Martin C. Messer 2001-03-22 09:33:24 EST
I get this again:

Errors Output 

   1.[Thu Mar 22 09:59:11 2001] null: error executing code for include
     /var/sandbox/echen/current/apps/panes/login/callback.apm: [Thu Mar 22
09:59:11 2001] null: DBD::Oracle::db prepare
     failed: ORA-03113: end-of-file on communication channel (DBD ERROR:
OCIStmtExecute/Describe) at
     /var/www/lib/WebUser.pm line 153. [Thu Mar 22 09:59:11 2001] null: ;
compiled to SCALAR(0x94bfaa4) at
     /var/www/lib/Apache/ASP.pm line 3672. , /var/www/lib/Apache/ASP.pm line
1473 

Debug Output 

   1.[Thu Mar 22 09:59:11 2001] null: error executing code for include
     /var/sandbox/echen/current/apps/panes/login/callback.apm: [Thu Mar 22
09:59:11 2001] null: DBD::Oracle::db prepare
     failed: ORA-03113: end-of-file on communication channel (DBD ERROR:
OCIStmtExecute/Describe) at
     /var/www/lib/WebUser.pm line 153. [Thu Mar 22 09:59:11 2001] null: ;
compiled to SCALAR(0x94bfaa4) at
     /var/www/lib/Apache/ASP.pm line 3672. , /var/www/lib/Apache/ASP.pm line
1473 


ASP to Perl Script 

  1: package Apps; ;; sub Apps::NoCache {  ;;  @_ = (); ;; use strict;;use vars
qw($Application $Session $Response $Server $Request);;use lib
qw(/var/sandbox/echen/current/apps);;;
  2:   # Page to prompt for login.  Uses saved_url to return from
  3:   # whence we came..
  4:  
  5:   my $title;
  6: 
  7:   if ($Apps::Param->{'title'}) {
  8:      $title = $Apps::Param->{'title'};
  9:   }
 10:   $title ||= Apps::gettext("My Account");
 11: 
 12:   Apps::Pane::Display('header', 'title'=>$title);
 13: 
 14: if (Apps::User::Entry()) {
 15:    # Redirect back...
 16:    my $url = Apps::UrlStack::pop();
 17:    if ($url) {
 18:      $Response->Redirect($url->{URL});
 19:      $Response->Finish();
 20:    }
 21: } ; $main::Response->WriteRef(\('
 22: 
 23: 
 24: <table width="90%" border="0" cellspacing="0" cellpadding="0"
align="CENTER">
 25:    <tr>
 26:            <td>
 27:            <FONT FACE="HELVETICA">
 28:            ')); msg({  }, 'Your account gives you preferred access to
redhat.com. Whether purchasing cool stuff from our store, getting support, or
taking advantage of one of our special offerings, having an account makes it
easy for you to do it all.'); ; $main::Response->WriteRef(\('
 29:            
 30:            <br>&nbsp;
 31:            <br>
 32:            <p><FONT FACE="HELVETICA" SIZE="3"
COLOR="#666666"><B>Login</B><BR></FONT>
 33: <table width="100%" border="0" cellspacing="0" cellpadding="0"><tr><td><IMG
SRC="/img/pixel.gif" WIDTH="1" HEIGHT="4" ALT=""></td></tr><tr><td
bgcolor="#999999"><IMG SRC="/img/pixel.gif" WIDTH="1" HEIGHT="1"
ALT=""></td></tr></table></p>
 34: 
 35:            ')); msg({  }, 'If you have previously created an account with
Red Hat, enter your user name and password and click "Log In".'); ;
$main::Response->WriteRef(\('
 36:            <p>
 37:            ')); Apps::pane({  type=>"login"  }, ''); ;
$main::Response->WriteRef(\('
 38:          <br>
 39:            <br>
 40:            </font>
 41:            
 42:            <p>
 43:            <FONT FACE="HELVETICA">
 44:            <p><FONT FACE="HELVETICA" SIZE="3" COLOR="#666666"><B>Create a
New Account</B><BR></FONT><table width="100%" border="0" cellspacing="0"
cellpadding="0"><tr><td><IMG SRC="/img/pixel.gif" WIDTH="1" HEIGHT="4"
ALT=""></td></tr><tr><td bgcolor="#999999"><IMG SRC="/img/pixel.gif" WIDTH="1"
HEIGHT="1" ALT=""></td></tr></table></p>
 45:            ')); msg({  }, 'In one quick step, you\'ll set up a basic
profile for use in all your transactions on redhat.com.'); ;
$main::Response->WriteRef(\(' 
 46:            <p>
 47:            ')); msg({  }, 'Then, tell us how you want to be contacted.
It\'s our goal to respect your privacy and we\'ll use the information you
provided at your request. For more information, see our'); ;
$main::Response->WriteRef(\(' <a href="/legal/privacy_statement.html">'));
msg({  }, 'Privacy Statement'); ; $main::Response->WriteRef(\('</a>.
 48:            <p>
 49:            <a href="/apps/user/join/index.html"><b>')); msg({  }, 'New
Login'); ; $main::Response->WriteRef(\('</b></a>
 50:            </td>
 51:    </tr>
 52: </table>
 53: 
 54: <br><br>
 55: 
 56: ')); Apps::pane({  type=>"footer"  }, ''); ; $main::Response->WriteRef(\('
 57: </FONT>'));;;no lib qw(/var/sandbox/echen/current/apps); ;; }

I'm connecting via CIPE, I wonder if there's something about my IP address it
doesn't like?
Comment 6 Eddie Chen 2001-03-22 14:53:35 EST
It works fine for me, Jay are you seeing the same problem?
I also changed customer id to customer number per bug 31708.
Comment 7 Martin C. Messer 2001-03-22 15:47:08 EST
Weird, works if I'm physically here in Meridian, but not via CIPE.

Anyway, looks good. I'm assuming none of the underlying code changed, just where
the redirect ends up, correct? Otherwise we'll need to test the account updating
itself...

Note You need to log in before you can comment on or make changes to this bug.