Bug 317931 - RHEL 4.5 PV SMP guest cause BUG() on RHEL 5.1beta xen
RHEL 4.5 PV SMP guest cause BUG() on RHEL 5.1beta xen
Status: CLOSED DUPLICATE of bug 251013
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xen (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 04:30 EDT by Kazuo Moriwaka
Modified: 2009-12-14 16:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 08:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazuo Moriwaka 2007-10-04 04:30:28 EDT
Description of problem:

When I boot RHEL4.5 PV SMP guest, it print BUG().

Version-Release number of selected component (if applicable):

on dom0:
kernel-xen-2.6.18-36.el5
xen-3.0.3-33.el5
xen-libs-3.0.3-33.el5

on domU:

kernel-xenU-2.6.9-55.0.9.EL
kernel-xenU-2.6.9-55.0.2.EL

How reproducible:

always

Steps to Reproduce:
1. setup it with vcpus=4 option
2. boot
  
Actual results:

with kernel-xenU-2.6.9-55.0.9.EL:
<snip>
CPU 1 irqstacks, hard=c033a000 soft=c031a000
------------[ cut here ]------------
kernel BUG at drivers/xen/core/smpboot.c:240!
invalid operand: 0000 [#1]
SMP
Modules linked in:
CPU:    0
EIP:    0061:[<c01fa12d>]    Not tainted VLI
EFLAGS: 00010282   (2.6.9-55.0.9.ELxenU)
EIP is at cpu_initialize_context+0x182/0x195
eax: ffffffea   ebx: 00000000   ecx: 00000001   edx: c15bd4c8
esi: 00000001   edi: c15bd6c8   ebp: c15f10e0   esp: c15bd4c4
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 1, threadinfo=c15bd000 task=c15f1670)
Stack: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Call Trace:
 [<c01f9fa1>] cpu_bringup_and_idle+0x0/0xa
 [<c01074d4>] divide_error+0x0/0x8
 [<c0107624>] debug+0x0/0x24
 [<c0107674>] int3+0x0/0x24
 [<c0107698>] overflow+0x0/0xc
 [<c01076a4>] bounds+0x0/0xc
 [<c01076b0>] invalid_op+0x0/0xc
 [<c0107604>] device_not_available+0x0/0x20
 [<c01076bc>] coprocessor_segment_overrun+0x0/0xc
 [<c01076c8>] invalid_TSS+0x0/0xc
 [<c01076d4>] segment_not_present+0x0/0xc
 [<c01076e0>] stack_segment+0x0/0xc
 [<c01076ec>] general_protection+0x0/0xc
 [<c0107704>] page_fault+0x0/0xc
 [<c0107710>] fixup_4gb_segment+0x0/0xc
 [<c01075ec>] coprocessor_error+0x0/0xc
 [<c01076f8>] alignment_check+0x0/0xc
 [<c01075f8>] simd_coprocessor_error+0x0/0xc
 [<c0107348>] system_call+0x0/0x30
 [<c010750c>] hypervisor_callback+0x0/0x34
 [<c01075ac>] failsafe_callback+0x0/0x40
 [<c0302476>] smp_prepare_cpus+0x185/0x1b4
 [<c010225e>] init+0x32/0x17a
 [<c010222c>] init+0x0/0x17a
 [<c0105341>] kernel_thread_helper+0x5/0xb
Code: c0 75 0d a1 a0 90 35 c0 8b 04 90 25 ff ff ff 7f c1 e0 0c 31 db 8d 54 24 04
89 84 24 ac 0a 00 00 89 f1 e8 d7 71 f0 ff 85 c0 74 08 <0f> 0b f0 00 7c ff 27 c0
81 c4 f4 0a 00 00 5b 5e 5f 5d c3 e8 84
 <0>Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception



with kernel-xenU-2.6.9-55.0.2.EL:
<snip>
CPU 1 irqstacks, hard=c033a000 soft=c031a000
------------[ cut here ]------------
kernel BUG at drivers/xen/core/smpboot.c:240!
invalid operand: 0000 [#1]
SMP
Modules linked in:
CPU:    0
EIP:    0061:[<c01f9c89>]    Not tainted VLI
EFLAGS: 00010282   (2.6.9-55.0.2.ELxenU)
EIP is at cpu_initialize_context+0x182/0x195
eax: ffffffea   ebx: 00000000   ecx: 00000001   edx: c15bd4c8
esi: 00000001   edi: c15bd6c8   ebp: c15f10e0   esp: c15bd4c4
ds: 007b   es: 007b   ss: 0068
Process swapper (pid: 1, threadinfo=c15bd000 task=c15f1670)
Stack: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
       00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
Call Trace:
 [<c01f9afd>] cpu_bringup_and_idle+0x0/0xa
 [<c01074d4>] divide_error+0x0/0x8
 [<c0107624>] debug+0x0/0x24
 [<c0107674>] int3+0x0/0x24
 [<c0107698>] overflow+0x0/0xc
 [<c01076a4>] bounds+0x0/0xc
 [<c01076b0>] invalid_op+0x0/0xc
 [<c0107604>] device_not_available+0x0/0x20
 [<c01076bc>] coprocessor_segment_overrun+0x0/0xc
 [<c01076c8>] invalid_TSS+0x0/0xc
 [<c01076d4>] segment_not_present+0x0/0xc
 [<c01076e0>] stack_segment+0x0/0xc
 [<c01076ec>] general_protection+0x0/0xc
 [<c0107704>] page_fault+0x0/0xc
 [<c0107710>] fixup_4gb_segment+0x0/0xc
 [<c01075ec>] coprocessor_error+0x0/0xc
 [<c01076f8>] alignment_check+0x0/0xc
 [<c01075f8>] simd_coprocessor_error+0x0/0xc
 [<c0107348>] system_call+0x0/0x30
 [<c010750c>] hypervisor_callback+0x0/0x34
 [<c01075ac>] failsafe_callback+0x0/0x40
 [<c0302476>] smp_prepare_cpus+0x185/0x1b4
 [<c010225e>] init+0x32/0x17a
 [<c010222c>] init+0x0/0x17a
 [<c0105341>] kernel_thread_helper+0x5/0xb
Code: c0 75 0d a1 a0 90 35 c0 8b 04 90 25 ff ff ff 7f c1 e0 0c 31 db 8d 54 24 04
89 84 24 ac 0a 00 00 89 f1 e8 7b 76 f0 ff 85 c0 74 08 <0f> 0b f0 00 d2 fa 27 c0
81 c4 f4 0a 00 00 5b 5e 5f 5d c3 e8 28
 <0>Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception


Expected results:
it boots.

Additional info:

When I set vcpu=1 in its configration, it boots well.
Comment 1 Chris Lalancette 2007-10-04 08:26:36 EDT

*** This bug has been marked as a duplicate of 251013 ***

Note You need to log in before you can comment on or make changes to this bug.