Bug 31800 - Esound does not produce sound from Gnome
Esound does not produce sound from Gnome
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: esound (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-14 15:48 EST by J. Alexander Jacocks
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 13:49:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. Alexander Jacocks 2001-03-14 15:48:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25 i686)


A Dell Inspiron 5000e (maestro 2E) produces sound fine when files are
catted to /dev/dsp or esdplay is used.  However, Gnome sound produces no
output.  No errors are seen in X logs, or system logs.

Reproducible: Always
Steps to Reproduce:
1.Install Wolverine on Inspiron 5000e
2.start X
3.play sound
	

Actual Results:  no output

Expected Results:  sound from speakers

/etc/modules.conf:
alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias sound-slot-0 maestro
alias sound-slot-1 maestro
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S

/etc/esd.conf:
[esd]
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2
spawn_wait_ms=100

lsmod:
Module                  Size  Used by
maestro                27536   0 
soundcore               4400   2  [maestro]
autofs                 11264   1  (autoclean)
cb_enabler              2720   0  (unused)
3c59x                  25344   1 
ds                      7280   2  [cb_enabler]
yenta_socket           11408   2 
pcmcia_core            43104   0  [cb_enabler ds yenta_socket]
ipchains               38848   0  (unused)
usb-uhci               20528   0  (unused)
usbcore                49440   1  [usb-uhci]

dmesg:
x version 2.4.2-0.1.25 (root@porky.devel.redhat.com) (gcc version 2.96
20000731 (Red Hat Linux 7.1 2.96-78)) #1 Fri Mar 9 20:45:41 EST 2001
BIOS-provided physical RAM map:
 BIOS-e820: 000000000009f800 @ 0000000000000000 (usable)
 BIOS-e820: 0000000000000800 @ 000000000009f800 (reserved)
 BIOS-e820: 0000000000019800 @ 00000000000e6800 (reserved)
 BIOS-e820: 000000000bef0000 @ 0000000000100000 (usable)
 BIOS-e820: 000000000000fc00 @ 000000000bff0000 (ACPI data)
 BIOS-e820: 0000000000000400 @ 000000000bfffc00 (ACPI NVS)
 BIOS-e820: 0000000000080000 @ 00000000fff80000 (reserved)
On node 0 totalpages: 49136
zone(0): 4096 pages.
zone(1): 45040 pages.
zone(2): 0 pages.
Kernel command line: BOOT_IMAGE=linux ro root=306
BOOT_FILE=/boot/vmlinuz-2.4.2-0.1.25 pci=biosirq
Initializing CPU#0
Detected 597.415 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1192.75 BogoMIPS
Memory: 185420k/196544k available (1367k kernel code, 10736k reserved, 91k
data, 236k init, 0k highmem)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Buffer-cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
VFS: Diskquotas version dquot_6.5.0 initialized
CPU: Before vendor init, caps: 0383f9ff 00000000 00000000, vendor = 0
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After vendor init, caps: 0383f9ff 00000000 00000000 00000000
CPU: After generic, caps: 0383f9ff 00000000 00000000 00000000
CPU: Common caps: 0383f9ff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 03
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.37 (20001109) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xfd9ae, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
PCI: Found IRQ 11 for device 00:04.0
PCI: The same IRQ used for device 00:04.1
PCI: The same IRQ used for device 01:00.0
PCI: Cannot allocate resource region 4 of device 00:07.1
  got res[1080:108f] for resource 4 of Intel Corporation 82371AB PIIX4 IDE
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.14)
Starting kswapd v1.8
pty: 256 Unix98 ptys configured
block: queued sectors max/low 122898kB/40966kB, 384 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1080-0x1087, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0x1088-0x108f, BIOS settings: hdc:DMA, hdd:pio
hda: FUJITSU MHK2120AT, ATA DISK drive
hdc: TOSHIBA DVD-ROM SD-C2402, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 23579136 sectors (12073 MB) w/512KiB Cache, CHS=1559/240/63, UDMA(33)
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Serial driver version 5.02 (2000-08-09) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
Real Time Clock Driver v1.10d
md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md.c: sizeof(mdp_super_t) = 4096
autodetecting RAID arrays
autorun ...
... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 1024 buckets, 8Kbytes
TCP: Hash tables configured (established 65536 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 236k freed
Adding Swap: 529160k swap-space (priority -1)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.251 $ time 20:57:43 Mar  9 2001
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 5 for device 00:07.2
PCI: The same IRQ used for device 00:08.0
usb-uhci.c: USB UHCI at I/O 0x1060, IRQ 5
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
SMSC Super-IO detection, now testing Ports 2F0, 370 ...
ip_conntrack (1535 buckets, 12280 max)
Linux PCMCIA Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
PCI: Found IRQ 11 for device 00:04.0
PCI: The same IRQ used for device 00:04.1
PCI: The same IRQ used for device 01:00.0
PCI: Found IRQ 11 for device 00:04.1
PCI: The same IRQ used for device 00:04.0
PCI: The same IRQ used for device 01:00.0
Yenta IRQ list 0698, PCI irq11
Socket status: 30000020
Yenta IRQ list 0698, PCI irq11
Socket status: 30000006
cs: cb_alloc(bus 2): vendor 0x10b7, device 0x5257
  got res[1800:187f] for resource 0 of PCI device 10b7:5257
  got res[10800000:1080007f] for resource 1 of PCI device 10b7:5257
  got res[10800080:108000ff] for resource 2 of PCI device 10b7:5257
  got res[10400000:1041ffff] for resource 6 of PCI device 10b7:5257
PCI: Enabling device 02:00.0 (0000 -> 0003)
3c59x.c:LK1.1.13 27 Jan 2001  Donald Becker and others.
http://www.scyld.com/network/vortex.html
See Documentation/networking/vortex.txt
eth0: 3Com PCI 3CCFE575CT Tornado CardBus at 0x1800, PCI: Setting latency
timer of device 02:00.0 to 64
 00:50:da:56:54:66, IRQ 11
  product code 5a45 rev 10.0 date 11-04-99
eth0: CardBus functions mapped 10800080->cc885080
  8K byte-wide RAM 5:3 Rx:Tx split, MII interface.
  MII transceiver found at address 0, status 7809.
  Enabling bus-master transmits and whole-frame receives.
eth0: scatter/gather disabled. h/w checksums enabled
NET4: Linux IPX 0.44 for NET4.0
IPX Portions Copyright (c) 1995 Caldera, Inc.
IPX Portions Copyright (c) 2000 Conectiva, Inc.
NET4: AppleTalk 0.18a for Linux NET4.0
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
eth0: using default media MII
eth0: using default media MII
spurious 8259A interrupt: IRQ7.
maestro: version 0.14 time 20:57:32 Mar  9 2001
PCI: Found IRQ 5 for device 00:08.0
PCI: The same IRQ used for device 00:07.2
maestro: Configuring ESS Maestro 2E found at IO 0x1400 IRQ 5
maestro:  subvendor id: 0x00cc1028
maestro: PCI power management capability: 0x7622
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.14 time 20:57:32 Mar  9 2001
PCI: Found IRQ 5 for device 00:08.0
PCI: The same IRQ used for device 00:07.2
maestro: Configuring ESS Maestro 2E found at IO 0x1400 IRQ 5
maestro:  subvendor id: 0x00cc1028
maestro: PCI power management capability: 0x7622
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.14 time 20:57:32 Mar  9 2001
PCI: Found IRQ 5 for device 00:08.0
PCI: The same IRQ used for device 00:07.2
maestro: Configuring ESS Maestro 2E found at IO 0x1400 IRQ 5
maestro:  subvendor id: 0x00cc1028
maestro: PCI power management capability: 0x7622
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.14 time 20:57:32 Mar  9 2001
PCI: Found IRQ 5 for device 00:08.0
PCI: The same IRQ used for device 00:07.2
maestro: Configuring ESS Maestro 2E found at IO 0x1400 IRQ 5
maestro:  subvendor id: 0x00cc1028
maestro: PCI power management capability: 0x7622
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
maestro: version 0.14 time 20:57:32 Mar  9 2001
PCI: Found IRQ 5 for device 00:08.0
PCI: The same IRQ used for device 00:07.2
maestro: Configuring ESS Maestro 2E found at IO 0x1400 IRQ 5
maestro:  subvendor id: 0x00cc1028
maestro: PCI power management capability: 0x7622
maestro: AC97 Codec detected: v: 0x83847609 caps: 0x6940 pwr: 0xf
maestro: 1 channels configured.
Comment 1 Elliot Lee 2001-03-15 13:14:24 EST
Please elaborate on what operations "Play sound" and "Gnome sound" involve. Too
vague for me, sorry! :)
Comment 2 J. Alexander Jacocks 2001-03-19 21:34:53 EST
By Gnome sound, I mean any Gnome applications that use the esd API's.  I.e. the 
Gnome Control Panel's sound tester, for events with sounds related to them.
Comment 3 Elliot Lee 2001-03-21 13:49:53 EST
Do any other sound apps fail besides the sound-properties control panel?
Comment 4 Elliot Lee 2001-08-26 17:54:50 EDT
Very old bug, can't reproduce, and no reply -> WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.