Bug 318111 - Strips whitespace by default when editing .c files
Summary: Strips whitespace by default when editing .c files
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: vim   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-04 11:55 UTC by Kjartan Maraas
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 12:53:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjartan Maraas 2007-10-04 11:55:49 UTC
Description of problem:

I tried editing gnome-app-helper.c in libgnomeui and saw that vim stripped a lot
of trailing whitespace behind my back. Didn't notice this until I saw in my
ChangeLog file that it had touched a bunch of functions that I knew I hadn't
changed myself. Has been this way for a while IIRC.

Tried with -u NONE -U NONE as well and that didn't make a difference.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Karsten Hopp 2008-04-07 11:44:34 UTC
which vim version was that ? I'm currently using 7.1.291-1.fc9 and can't reproduce
this in vim or gvim.
Please close this report if you've updated vim in the meantime and this
behaviour isn't reproducable anymore.

Comment 2 Kjartan Maraas 2008-04-07 12:53:23 UTC
Looks like it has been fixed. Thanks.


Note You need to log in before you can comment on or make changes to this bug.