Bug 31818 - QA0309 - Flash and UDMA IDE drives on same channel locks up
QA0309 - Flash and UDMA IDE drives on same channel locks up
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-14 21:41 EST by R P Herrold
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-08 13:21:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci from the motherboard which locks ... (1.95 KB, text/plain)
2001-03-14 23:10 EST, R P Herrold
no flags Details
dmesg frpm the motherboard -- shows drive info (4.56 KB, text/plain)
2001-03-14 23:11 EST, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2001-03-14 21:41:56 EST
I had no trouble installing QA0309 when there was just 
one hard drive on the first (primary IDE controller) cable.  

However, when I add the flash drive that cable, 
RH chokes on the hard drive.  

It doesn't matter which is master or slave.  
The error messages are a bit different, 
but RH gets stuck just the same.  

The _symptoms_ seems to complain about the hard drive, 
when the flash drive is added.  
(Yes, I am paying attention to the master/slave jumpers.)

hda: 12504240 sectors (6402 MB) w/490KiB Cache, CHS=778/255/63, UDMA(33)
hdb: 125440 sectors (64 MB) w/1KiB Cache, CHS=490/8/32
Partition checks
 hda:hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14

I have also tried adding the flash disk as the secondary slave (hdd).  
QA0309 doesn't choke on it that way.  

The BIOS does support booting IDE3.  

I had no trouble mixing these drives with RH6.2.  But
that was with a completely different motherboard.
Comment 1 R P Herrold 2001-03-14 23:10:41 EST
Created attachment 12703 [details]
lspci from the motherboard which locks ...
Comment 2 R P Herrold 2001-03-14 23:11:24 EST
Created attachment 12704 [details]
dmesg frpm the motherboard -- shows drive info
Comment 3 R P Herrold 2001-03-14 23:16:07 EST
Extract of demsg with lock showing the drives:

 
hda: SAMSUNG SV0644A (6.40GB), ATA DISK drive
hdb: SanDisk SDP3B-64, ATA DISK drive
hdc: FX320M, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 12504240 sectors (6402 MB) w/490KiB Cache, CHS=778/255/63, UDMA(33)
hdb: 125440 sectors (64 MB) w/1KiB Cache, CHS=490/8/32
Partition check:
 hda:hda: timeout waiting for DMA
ide_dmaproc: chipset supported ide_dma_timeout func only: 14
Comment 4 Arjan van de Ven 2001-03-15 04:50:01 EST
Can you try booting with "ide=nodma" on the "append" line in lilo?
(or added to the kernel name on the lilo prompt)
Comment 5 R P Herrold 2001-03-15 15:47:40 EST
PROGRESS !

At the first CDROM installation prompt, I entered:
 
   linux ide=nodma
 
and it got past where it had been stuck before.

It went on to a graphical install that I am working my way
through.  This is progress.     

------------------------

I searched high and low through Buzzilla for this clue ... may we un-hide it?
Comment 6 R P Herrold 2001-03-15 17:58:05 EST
It works, mostly -- the end of job preparation of the bootable system does not
get automatically passed the boot parameter, and I neglected to add it into the
options -- no big deal -- but perhaps if an options addendum is used for
installing, Anaconda should complain or pre-stage the supplied text
automatically -- I'll think about this one.
 
To get the installation started, I entered linux ide=nodma
at the first prompt offered by the installation CDROM.
After the installation was complete, I could not boot
automatically from either floppy or hard drive, but
could boot if I entered linux ide=nodma at Lilo prompt.

I've since fixed lilo.conf to boot automatically, by adding an append line with
the parameter of the form:

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
append="ide=nodma"
linear
default=linux

image=/boot/vmlinuz-2.4.2-0.1.23
      label=linux
      read-only
      root=/dev/hda10                           

                                                        
... but getting this documented, or into the doco stream for folks with flash 
would be a Good Thing ...
Comment 7 Michael K. Johnson 2001-03-15 19:26:31 EST
ide=nodma was sent to documentation and to support, don't worry.
It's in many bugzilla reports; perhaps you didn't look at closed
reports?

Could you please provide the exact contents of /proc/ide/hdX/model
for your flash drive?  We can possibly make ide=nodma unnecessary
for your machine if you do.
Comment 8 R P Herrold 2001-03-15 21:18:03 EST
hmmm I searched kernel with argument Flash in the description and subject ...

Exact contents are:

SanDisk SDP3B-64

(I untarred, and it was identical ...)
Comment 9 Arjan van de Ven 2001-03-16 06:57:19 EST
This ID is added to our blacklist; if kernels 0.1.30 or later (when available)
do not fix your problem, please reopen this bug.
Comment 10 Michael K. Johnson 2001-03-16 08:52:43 EST
No one has reported this problem with flash before, which is why
your search for flash didn't find it.  It has been reported (and
generally worked around in the same way) for several CDROM drives
now.  Just FYI...
Comment 11 Need Real Name 2001-03-18 16:46:31 EST
An ACER 40x IDE CD-ROM also needs to be blacklisted:

# cat /proc/ide/hdc/model
ATAPI CD-ROM DRIVE 40X MAXIMUM
Comment 12 R P Herrold 2001-04-08 13:11:45 EDT
Blacklist not updated for SanDisk SDP3B-32
Comment 13 Arjan van de Ven 2001-04-08 13:21:05 EDT
-32 added to blacklist.
Are there other models you know of ?
Comment 14 Arjan van de Ven 2001-04-18 10:47:56 EDT
device is blacklisted in the seawolf kernel

Note You need to log in before you can comment on or make changes to this bug.