Bug 31840 - aha1542 driver does not detect valid devices
aha1542 driver does not detect valid devices
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-15 00:19 EST by Dave Miller
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 11:18:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Miller 2001-03-15 00:19:32 EST
Installer reports no valid devices.  Contents of /proc/scsi under Red Hat
6.2:

[dave@bend ~]# ls /proc/scsi
aha1542/  scsi
[dave@bend ~]# ls /proc/scsi/aha1542
0
[dave@bend ~]# cat /proc/scsi/scsi 
Attached devices: 
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SEAGATE  Model: ST32155N         Rev: 0532
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: SEAGATE  Model: ST34520N         Rev: 1444
  Type:   Direct-Access                    ANSI SCSI revision: 02

Note: due to a problem with the wolverine boot.img, I downloaded the
rawhide boot.img and drivers.img files as per the resolution of bug 31766.
Comment 1 Michael K. Johnson 2001-03-15 12:47:50 EST
Are you trying to install wolverine with the rawhide boot.img and
drivers.img?
Comment 2 Dave Miller 2001-03-15 13:36:11 EST
Yes.  I am working with a system that has an AMD 5x86/133 CPU.  There is a bug
in the Wolverine boot.img that causes it to hang on this CPU.  See bug 31766. 
The resolution for 31766 was to use the rawhide boot.img.  I assumed I needed
the corresponding drivers.img for compatibility.  I can try the wolverine
drivers.img if you think this might work.
Comment 3 Michael K. Johnson 2001-03-15 19:21:38 EST
You can't mix modules from wolverine with modules from rawhide.
Are you sure that isn't happening?  Can you see if the module is
being inserted without error messages?
Comment 4 Dave Miller 2001-03-16 00:20:24 EST
Slightly more information...  decided to "play around with it" some more tonight.  The fdisk selection window lists the two SCSI drives on the system.  
I had previously been using disk druid.  This mean that aha1542.o is able to probe for devices however I was not able to select either drive.  I also tried 
manually doing a mknod from an alternate console (e.g., mknod --mode=550 /tmp/sda 8 0) but with no luck: fdisk /tmp/sda barfed.  This is not something 
I usually mess around with so its probable that I don't have the syntax or something else right for what I want to do.
Comment 5 Dave Miller 2001-03-16 02:14:21 EST
I am not mixing rawhide modules with wolverine modules (although I did ==> ask <== if that was something to try).  I pulled down the boot.img and 
corresponding drivers.img from the VA Linux rawhide mirror.  These were found at /pub/mirrors/redhat/rawhide/i386/images and are dated from Sunday 11 
March.  Syslinux reports version 1.52 at startup. The syslog from a recent attempt to make the install work.

<4>Linux version 2.4.2-0.1.25BOOT (root@porky.devel.redhat.com) (gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-78)) #1 Fri Mar 9 18:32:24 EST 
2001
<4>BIOS-provided physical RAM map:
<4> BIOS-88: 000000000009f000 @ 0000000000000000 (usable)
<4> BIOS-88: 0000000003f00000 @ 0000000000100000 (usable)
<4>On node 0 totalpages: 16384
<4>zone(0): 4096 pages.
<4>zone(1): 12288 pages.
<4>zone(2): 0 pages.
<4>Kernel command line: initrd=initrd.img lang= devfs=nomount vga=788 BOOT_IMAGE=vmlinuz auto
<4>Initializing CPU#0
<4>Console: colour VGA+ 80x25
<4>Calibrating delay loop... 66.56 BogoMIPS
<4>Memory: 56816k/65536k available (1194k kernel code, 8332k reserved, 84k data, 108k init, 0k highmem)
<4>Checking if this processor honours the WP bit even in supervisor mode... Ok.
<4>Dentry-cache hash table entries: 8192 (order: 4, 65536 bytes)
<4>Buffer-cache hash table entries: 4096 (order: 2, 16384 bytes)
<4>Page-cache hash table entries: 16384 (order: 5, 131072 bytes)
<4>Inode-cache hash table entries: 4096 (order: 3, 32768 bytes)
<4>CPU: Before vendor init, caps: 00000001 00000000 00000000, vendor = 2
<4>CPU: After vendor init, caps: 00000001 00000000 00000000 00000000
<4>CPU: After generic, caps: 00000001 00000000 00000000 00000000
<4>CPU: Common caps: 00000001 00000000 00000000 00000000
<4>CPU: AMD Am5x86-WT stepping 04
<6>Checking 'hlt' instruction... OK.
<6>Checking for popad bug... OK.
<4>POSIX conformance testing by UNIFIX
<4>PCI: No PCI bus detected
<6>Linux NET4.0 for Linux 2.4
<6>Based upon Swansea University Computer Society NET3.039
<4>Starting kswapd v1.8
<4>pty: 256 Unix98 ptys configured
<4>block: queued sectors max/low 37637kB/12545kB, 128 slots per queue
<4>RAMDISK driver initialized: 16 RAM disks of 4608K size 1024 blocksize
<6>Uniform Multi-Platform E-IDE driver Revision: 6.31
<4>ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
<4>hda: Maxtor 81620A3, ATA DISK drive
<4>hdb: ATAPI CDROM, ATAPI CD/DVD-ROM drive
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<6>hda: 3175200 sectors (1626 MB) w/256KiB Cache, CHS=3150/16/63
<6>Partition check:
<6> hda: [PTBL] [787/64/63] hda1 hda2 hda3
<6>Floppy drive(s): fd0 is 1.44M
<6>FDC 0 is a National Semiconductor PC87306
<5>RAMDISK: Compressed image found at block 0
<4>Freeing initrd memory: 732k freed
<6>loop: loaded (max 8 devices)
<6>Serial driver version 5.02 (2000-08-09) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
<6>ttyS00 at 0x03f8 (irq = 4) is a 16450
<6>ttyS01 at 0x02f8 (irq = 3) is a 16450
<6>md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
<4>md.c: sizeof(mdp_super_t) = 4096
<6>autodetecting RAID arrays
<4>autorun ...
<4>... autorun DONE.
<6>NET4: Linux TCP/IP 1.0 for NET4.0
<6>IP Protocols: ICMP, UDP, TCP
<4>IP: routing cache hash table of 512 buckets, 4Kbytes
<4>TCP: Hash tables configured (established 16384 bind 16384)
<6>NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
<4>VFS: Mounted root (ext2 filesystem).
<4>fatfs: bogus cluster size
<4>VFS: Can't find a valid MSDOS filesystem on dev 02:00.
<4>eth0: 3c509 at 0x300, 10baseT port, address  00 20 af 04 c4 ca, IRQ 10.
<4>3c509.c:1.16 (2.2) 2/3/98 becker@cesdis.gsfc.nasa.gov.
<4>eth0: Setting Rx mode to 1 addresses.
<6>SCSI subsystem driver Revision: 1.00
<6>Configuring Adaptec (SCSI-ID 7) at IO:330, IRQ 9, DMA priority 5
<6>aha1542.c: Using extended bios translation
<6>scsi0 : Adaptec 1542
<4>  Vendor: SEAGATE   Model: ST32155N          Rev: 0532
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>  Vendor: SEAGATE   Model: ST34520N          Rev: 1444
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<6>Adding Swap: 133048k swap-space (priority -1)
Comment 6 Alan Cox 2003-06-09 11:18:53 EDT
Seems to be an old installer bug. There isnt useful info we need to keep here so
I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.