Bug 318441 - 20071004 update made indirect yum calls go crazy
20071004 update made indirect yum calls go crazy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 318821 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 11:06 EDT by Julian Sikorski
Modified: 2014-01-21 17:59 EST (History)
6 users (show)

See Also:
Fixed In Version: f7updates
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 10:18:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of strace pirut (519.76 KB, application/x-bzip2)
2007-10-04 12:00 EDT, Julian Sikorski
no flags Details
yum.log output (4.82 KB, text/plain)
2007-10-04 12:04 EDT, drago01
no flags Details

  None (edit)
Description Julian Sikorski 2007-10-04 11:06:18 EDT
Description of problem:
Today I installed a bunch of updates:

Oct 04 15:20:31 Updated: openoffice.org-core - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:21:21 Updated: dbus-glib - 0.73-3.fc7.x86_64
Oct 04 15:21:23 Updated: libselinux - 2.0.14-9.fc7.x86_64
Oct 04 15:21:33 Updated: libpurple - 2.2.1-1.fc7.x86_64
Oct 04 15:21:34 Updated: libselinux - 2.0.14-9.fc7.i386
Oct 04 15:21:36 Updated: kde-filesystem - 3.92-9.fc7.noarch
Oct 04 15:22:06 Updated: kdelibs - 6:3.5.7-22.fc7.x86_64
Oct 04 15:22:48 Updated: kdebase - 6:3.5.7-13.1.fc7.x86_64
Oct 04 15:23:00 Updated: kdelibs-devel - 6:3.5.7-22.fc7.x86_64
Oct 04 15:23:04 Updated: openoffice.org-calc - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:23:05 Updated: libnetfilter_conntrack - 0.0.81-1.fc7.x86_64
Oct 04 15:23:07 Updated: dbus-glib - 0.73-3.fc7.i386
Oct 04 15:23:08 Updated: fuse-libs - 2.7.0-6.fc7.x86_64
Oct 04 15:23:09 Updated: sip - 4.6-2.fc7.x86_64
Oct 04 15:23:10 Updated: icedax - 1.1.6-5.fc7.x86_64
Oct 04 15:23:11 Updated: libselinux-python - 2.0.14-9.fc7.x86_64
Oct 04 15:23:12 Updated: openoffice.org-math - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:23:13 Updated: openoffice.org-xsltfilter - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:23:37 Updated: fast-user-switch-applet - 2.17.4-5.fc7.x86_64
Oct 04 15:23:41 Updated: openoffice.org-draw - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:23:42 Updated: openoffice.org-base - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:23:51 Updated: tzdata - 2007h-1.fc7.noarch
Oct 04 15:23:52 Updated: rsync - 2.6.9-3.fc7.x86_64
Oct 04 15:23:53 Updated: sip-devel - 4.6-2.fc7.x86_64
Oct 04 15:23:53 Updated: openoffice.org-graphicfilter - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:23:56 Updated: alsa-utils - 1.0.14-2.fc7.x86_64
Oct 04 15:23:58 Updated: libselinux-devel - 2.0.14-9.fc7.x86_64
Oct 04 15:23:59 Updated: wodim - 1.1.6-5.fc7.x86_64
Oct 04 15:24:03 Updated: xchat - 1:2.8.4-5.fc7.x86_64
Oct 04 15:24:05 Updated: fuse - 2.7.0-6.fc7.x86_64
Oct 04 15:24:06 Updated: genisoimage - 1.1.6-5.fc7.x86_64
Oct 04 15:24:07 Updated: xorg-x11-xtrans-devel - 1.0.3-2.1.fc7.x86_64
Oct 04 15:24:10 Updated: openoffice.org-writer - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:24:13 Updated: openoffice.org-impress - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:24:19 Updated: polyester - 1.0.2-1.fc7.x86_64
Oct 04 15:24:45 Updated: pidgin - 2.2.1-1.fc7.x86_64
Oct 04 15:24:58 Updated: openoffice.org-langpack-pl_PL - 1:2.2.1-18.2.fc7.x86_64
Oct 04 15:24:59 Updated: dbus-glib-devel - 0.73-3.fc7.x86_64
Oct 04 15:25:00 Updated: kdebase-devel - 6:3.5.7-13.1.fc7.x86_64

After that, any attempt to run yum indirectly (puplet, yum-updatesd-helper,
pirut) ends up with bandwidth being fully hogged by the mentioned app . What is
more pup/pirut window never shows up. yum itself works fine (after you kill the
misbehaving app of course). I did run yum clean all, rpm --rebuilddb and suck,
but none of these helped. I'm not a netstat guru, but it seems like the software
is trying to grab somewhere from numerous fedora mirrors.

Additional info:
I guess it's not a yum bug, but I have no idea what to file it against otherwise.
Comment 1 Julian Sikorski 2007-10-04 11:07:53 EDT
is trying to grab somewhere from numerous fedora mirrors.
                  ^^ I mean something, of course.
Comment 2 Julian Sikorski 2007-10-04 12:00:04 EDT
Created attachment 215981 [details]
output of strace pirut

The strace log of pirut. It was killed when it started to download.
Comment 3 drago01 2007-10-04 12:04:48 EDT
Created attachment 216031 [details]
yum.log output

I am seeing the same on my box and I attached the yum.log file as requested.
Comment 4 Seth Vidal 2007-10-04 12:19:14 EDT
okay - we've got broken metadata in the updates for f7 which is causing this.
adding luke and jesse
Comment 5 Seth Vidal 2007-10-04 13:18:39 EDT
*** Bug 318821 has been marked as a duplicate of this bug. ***
Comment 6 Luke Macken 2007-10-04 14:19:21 EDT
Interesting issue.  The repodata composed from our end looks fine, but for some
reason the comps-f7.xml that hit the mirrors has a different checksum, which
threw off yum/pup/pirut.

Bodhi just finished mashing a fresh f7-updates, so hopefully once this hits the
mirrors this issue will be resolved.

We still need to figure out what caused this.
Comment 7 Luke Macken 2007-10-04 14:23:26 EDT
The new comps-f7.xml that just hit the f7-updates repos looks good.  This should
hopefully fix your problem.

Note You need to log in before you can comment on or make changes to this bug.