Bug 318521 - iscsi fixes needed against 2.6.21 realtime kernel
iscsi fixes needed against 2.6.21 realtime kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 11:22 EDT by Tim Burke
Modified: 2008-02-27 14:57 EST (History)
0 users

See Also:
Fixed In Version: 2.6.21-45.el5rt
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 11:46:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upstream ISCSI fixes backported to 2.6.21-rt kernel (193.15 KB, patch)
2007-11-09 11:45 EST, Clark Williams
no flags Details | Diff

  None (edit)
Description Tim Burke 2007-10-04 11:22:31 EDT
Mike Christi mails:

Stock 2.6.21 has some bugs on the IO error paths and shutdown.

So in short :) , .21 and .23 has a bug during shutdown when using targets that
are using a write back cache. The problem is that in .21 the scsi mid layer
changed the userspace interface behavior for some operation that the iscsi tools
use. We have a fix for upstream for .24 or .25 (depending on when we finish
testing and push upstream and what feature window is open), but until then we
have a workaround in userspace.
Comment 1 Clark Williams 2007-11-09 11:45:09 EST
Created attachment 253021 [details]
Upstream ISCSI fixes backported to 2.6.21-rt kernel

Patch from Mike Christie

Note You need to log in before you can comment on or make changes to this bug.