Bug 318721 - php-pear-PHPUnit-3.0.6-1.fc7 conflicts with php-pear-PHPUnit2-2.3.6-1.fc6
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with php-pear-PHPUnit2-2.3.6-1.fc6
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php-pear-PHPUnit (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Stone
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 12:26 EDT by Gerald Cox
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 13:39:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2007-10-04 12:26:02 EDT
Description of problem:
Receive conflict message when updating php-pear-PHPUnit.  PHPUnit2 also has a
fc6 filename???

Version-Release number of selected component (if applicable):
php-pear-PHPUnit-3.0.6-1.fc7


How reproducible:
yum install php-pear-PHPUnit


Steps to Reproduce:
1.  yum install php-pear-PHPUnit
2.
3.
  
Actual results:
Transaction Check Error:
  file /usr/bin/phpunit from install of php-pear-PHPUnit-3.0.6-1.fc7 conflicts
with file from package php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Extensions/ExceptionTestCase.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Extensions/PerformanceTestCase.php from install
of php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Extensions/RepeatedTest.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Extensions/TestDecorator.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Extensions/TestSetup.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/Assert.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/AssertionFailedError.php from install
of php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/ComparisonFailure.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/Error.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/IncompleteTest.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/IncompleteTestError.php from install
of php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/Test.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/TestCase.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/TestListener.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/TestResult.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/TestSuite.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Framework/Warning.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Runner/BaseTestRunner.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Runner/IncludePathTestCollector.php from install
of php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Runner/StandardTestSuiteLoader.php from install
of php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Runner/TestCollector.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Runner/TestSuiteLoader.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Runner/Version.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/TextUI/ResultPrinter.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/TextUI/TestRunner.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Util/Filter.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Util/Log/PEAR.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6
  file /usr/share/pear/PHPUnit2/Util/Log/XML.php from install of
php-pear-PHPUnit-3.0.6-1.fc7 conflicts with file from package
php-pear-PHPUnit2-2.3.6-1.fc6



Expected results: Successful installation.


Additional info:
Comment 1 Christopher Stone 2007-10-04 18:54:26 EDT
Hi Gerald, php-pear-PHPUnit2 and php-pear-PHPUnit are supposed to conflict with
each other.  They were both provided in F-7 to allow people using version 2.x to
transition over to version 3.x.

New and future applications should use the php-pear-PHPUnit package which
contains version 3.x.  php-pear-PHPUnit2 is only provided for legacy
applications and will no longer be available with Fedora 8.

The reason why php-pear-PHPUnit2 still uses an fc6 repo tag is because a new
version was never built for Fedora 7.  This is not a bug since it is noarch, no
rebuilding was required.

If you want to use the latest version of PHPUnit, I would recommend:

yum remove php-pear-PHPUnit2
yum install php-pear-PHPUnit

Please let me know if you have any further questions.

Note You need to log in before you can comment on or make changes to this bug.