Bug 318881 - Crackle in audio since August update (absent in Live CD)
Crackle in audio since August update (absent in Live CD)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 13:53 EDT by Richard Schwarting
Modified: 2008-01-14 13:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 13:29:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig from installed system with crackle (47.26 KB, text/plain)
2007-10-04 13:53 EDT, Richard Schwarting
no flags Details
scsconfig from Live CD without crackle (142.26 KB, text/plain)
2007-10-04 13:54 EDT, Richard Schwarting
no flags Details

  None (edit)
Description Richard Schwarting 2007-10-04 13:53:43 EDT
Description of problem:

The audio crackles now.  It started a week or so before Monday, August 13th. 
Checking the Fedora 7 Test Update mailing list, I can see that these two
potentially relevant packages may have caused it.
Aug  8 - alsa-plugins-1.0.14-1.fc7
Jul 30 - kernel-2.6.22.1-41.fc7

At the time, I swore a little and blamed my speakers.  But when recently trying
a Live CD on my of Fedora 7 (without any recent updates, of course), I heard
sounds crisp and clear.  


Version-Release number of selected component (if applicable):


How reproducible:

Always.  Running the Fedora 7 Live CD, my sound is always clear; from my
installation, since August, the sound always crackles. 

Steps to Reproduce:
1. install Fedora 7 Test 4
2. use it over a period of 7 months, subscribing to Fedora Updates for updated
packages.
3. play music anywhere on your sister
  
Actual results:
* after step 2, all audio played is now accompanied with a crackle!

Expected results:
* after step 2, all audio remains as clear as it did at initial installation.

Additional info:
* at one point, I messed around with modprobe.conf and asound.state a little,
following instructions on Some Forum to enable my microphone (which did not
work) and to get sound from both speakers (rather than just the left (my right)
one).  The instructions succeeded, though the change that made things crackly
also broke my microphone again (I had reason to believe that the microphone
itself was faulty, and did not think twice about it).  
Reverting the modprobe.conf and asound.state to the one found on the Fedora 7
Live CD does not improve my situation.
Comment 1 Richard Schwarting 2007-10-04 13:53:43 EDT
Created attachment 216151 [details]
scsconfig from installed system with crackle
Comment 2 Richard Schwarting 2007-10-04 13:54:51 EDT
Created attachment 216161 [details]
scsconfig from Live CD without crackle
Comment 3 Richard Schwarting 2007-10-04 22:14:53 EDT
Running aplay on a wav file in Fedora 8 Test 3 also plays clearly, leading me to
believe that either something peculiar has gone awry with my configuration or a
bug was introduced and has now been fixed. 

I can't provide a scsconfig.log from F8T3 due to bug 302961 :(  (unless there is
a way to run the test from the command line that I'm unaware of!)
Comment 4 Chuck Ebbert 2007-10-05 18:21:08 EDT
Tru editing modprobe.conf and adding "model" options for the HDA Intel driver
from the list at:

  http://fedoraproject.org/wiki/KernelHdaDriverOptions

Use the ones from the ALC883 column, and try one at a time.

First attempt should be something like this:

options snd-hda-intel index=0 model=medion

You will have to reboot each time, or unload and reload the driver after each
change.
Comment 5 Richard Schwarting 2007-10-06 14:07:51 EDT
Hello.

Thanks for getting back to me.  I think this could be closed as NotABug as it's
almost certainly my fault for configuration changes I made a while back (in
order to get sound out of both speakers and a working mic.)

I ended up using my Google Web History to track down the exact instructions I
had followed when " messed around with modprobe.conf and asound.state a little,
following instructions on Some Forum to enable my microphone" and discovered
another file I had been told to edit (modprobe.d/modprobe.conf.dist).  I copied
fresh copies of them from my Fedora 7 live CD and re-installed the
fedora-updates Alsa packages (having moved /etc/alsa away).

With the old configuration and the recent packages, my microphone and both
speakers seem to work and I do not have the crackle.  

Thanks for the response and your time, again.

Note You need to log in before you can comment on or make changes to this bug.