Bug 319281 - Error when upgrading gnbd-kmod - Broken pipe
Error when upgrading gnbd-kmod - Broken pipe
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnbd-kmod (Show other bugs)
5.0
All Linux
high Severity low
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 17:05 EDT by Chris Feist
Modified: 2009-04-16 18:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 14:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Feist 2007-10-04 17:05:45 EDT
There are problems while attempt to upgrade to the new "gnbd-kmod" 
packages (gnbd-kmod-debuginfo-0.1.4-11.el5.*.rpm):

UpgradeTest =====================================
doRpmCommand: rpm -U
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/i686/gnbd-kmod-debuginfo-0.1.4-11.el5.i686.rpm
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/i686/kmod-gnbd-0.1.4-11.el5.i686.rpm
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/i686/kmod-gnbd-PAE-0.1.4-11.el5.i686.rpm
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/i686/kmod-gnbd-xen-0.1.4-11.el5.i686.rpm
doRpmCommand-result (0): /sbin/weak-modules: line 73: echo: write error: Broken
pipe

Upgrade test FAILED
Output from RPM Command:
/sbin/weak-modules: line 73: echo: write error: Broken pipe

The same behaviour can be seen for x86_64 packages
(kmod-gnbd-0.1.4-11.el5.x86_64.rpm):

UpgradeTest =====================================
doRpmCommand: rpm -U
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/x86_64/gnbd-kmod-debuginfo-0.1.4-11.el5.x86_64.rpm
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/x86_64/kmod-gnbd-0.1.4-11.el5.x86_64.rpm
/mnt/redhat/brewroot/packages/gnbd-kmod/0.1.4/11.el5/x86_64/kmod-gnbd-xen-0.1.4-11.el5.x86_64.rpm
doRpmCommand-result (0): /sbin/weak-modules: line 73: echo: write error: Broken
pipe

Upgrade test FAILED
Output from RPM Command:
/sbin/weak-modules: line 73: echo: write error: Broken pipe
Comment 3 Kiersten (Kerri) Anderson 2007-10-05 13:07:32 EDT
Should component name be changed in the bugzilla?
Comment 4 Chris Feist 2007-10-05 14:26:34 EDT
This bug was caused because the wrong version of module-init-tools were being
used for the TPS reports.  Closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.