Bug 319811 - [hts-5.1.1][x86_64][cdrom][EL4-U6] - cdrom calls missing HAL APIs
[hts-5.1.1][x86_64][cdrom][EL4-U6] - cdrom calls missing HAL APIs
Status: CLOSED DUPLICATE of bug 313501
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 02:45 EDT by Satyabrata Maitra
Modified: 2008-07-16 17:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 12:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
x86_64-cdrom-El4-U6-.log files and traceback (330.00 KB, application/x-tar)
2007-10-05 02:45 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-10-05 02:45:58 EDT
Description of problem:
When tested with hts-5.1.1 for cdrom on EL4-U6 in x86_64 arch, its giving
following traceback error. .log files and other necessary files are attached
with this bug.

Traceback :-
Running ./cdrom.py:
lshal version 0.4.2
  block.device = '/dev/hda'  (string)
Traceback (most recent call last):
  File "./cdrom.py", line 692, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/hts/lib/hts/test.py", line 226, in do
    return self.run()
  File "./cdrom.py", line 550, in run
    features = self.configDeviceHAL(cdromDevice,cdromDeviceUDI)
  File "./cdrom.py", line 133, in configDeviceHAL
    cdromDevice = hal.getDevice(cdromUDI)
  File "/usr/share/hts/lib/hts/hal.py", line 29, in getDevice
    return Device(Constants.hal, self.getDeviceProperties(udi))
  File "/usr/share/hts/lib/hts/hal.py", line 39, in getDeviceProperties
    return self.__GetDevice(udi).GetAllProperties()
  File "/usr/share/hts/lib/hts/hal.py", line 32, in __GetDevice
    dev_obj=self.bus.get_object('org.freedesktop.Hal',udi)
AttributeError: SystemBus instance has no attribute 'get_object'
...finished running ./cdrom.py, exit code=1

Version-Release number of selected component (if applicable):
hts-5.1.1
Tree followed - 20070927.0

How reproducible:
Tried Once, and reproduced

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Its giving traceback

Expected results:
It should PASS

Additional info:
Comment 1 Satyabrata Maitra 2007-10-05 02:45:58 EDT
Created attachment 217131 [details]
x86_64-cdrom-El4-U6-.log files and traceback
Comment 2 Greg Nichols 2007-10-05 10:39:07 EDT
The cdrom test needs to account for the lack of HAL API's in RHEL4.
Comment 3 Greg Nichols 2007-10-12 12:19:31 EDT

*** This bug has been marked as a duplicate of 313501 ***

Note You need to log in before you can comment on or make changes to this bug.