Bug 319871 - Pidgin 2.2.1 missing Bonjour plugin
Pidgin 2.2.1 missing Bonjour plugin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 04:17 EDT by James Gregory
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.2.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 12:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for pidgin.spec (841 bytes, patch)
2007-10-07 14:45 EDT, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description James Gregory 2007-10-05 04:17:47 EDT
Description of problem:
It would appear the Pidgin 2.2.1 has not been compiled with support for Bonjour.
The Bonjour plugin (libbonjour.so) doesn't seem to be available, you cannot
select "Bonjour" from the protocol list, and existing Bonjour accounts just come
up as "Unknown" in the Accounts menu.

Version-Release number of selected component (if applicable):
libpurple & Pidgin 2.2.1 

How reproducible:
Every time

Steps to Reproduce:
1. Load Pidgin
2. Attempt to add a Bonjour account - it isn't visible from the list of protocols
  
Actual results:
You cannot use Bonjour

Expected results:
You should be able to use Bonjour

Additional info:
None
Comment 1 Warren Togami 2007-10-05 10:01:57 EDT
The fix for Bug #312131 seems to have broken the Bonjour plugin in F7.  Any ideas?
Comment 2 Michel Alexandre Salim 2007-10-06 13:47:31 EDT
Looking at the Koji build log, this is the offending part -- missing BR on
avahi-glib-devel, which provides avahi-glib/glib-malloc.h .

Actually, it is broken in F8 too. The only reason mine still works is that I
have libbonjour.so from an earlier install, which the upgrade did not remove
(bad!). Not sure how that happened, since the spec file has this for libpurple:
%{_libdir}/purple-2/

-----
checking for AVAHI... no
no
checking avahi-client/client.h usability... yes
checking avahi-client/client.h presence... yes
checking for avahi-client/client.h... yes
checking avahi-glib/glib-malloc.h usability... no
checking avahi-glib/glib-malloc.h presence... no
checking for avahi-glib/glib-malloc.h... no
checking for avahi_client_new in -lavahi-client... yes
Comment 3 Michel Alexandre Salim 2007-10-06 13:56:23 EDT
My local build (which linked against the installed avahi-glib-devel, my bad) had
this listed as part of libpurple:

/usr/lib64/purple-2/libbonjour.so

Is it possible that if pidgin is running when libpurple is upgraded, the file
did not get deleted?
Comment 4 James Gregory 2007-10-06 17:22:51 EDT
I closed Pidgin to update it, so I presume that is why mine got deleted (and not
yours Michel). However, I guess this will need fixing as people who either
upgrade now or install Fedora from fresh won't get the Bonjour plugin.
Comment 5 Michel Alexandre Salim 2007-10-07 14:45:08 EDT
Created attachment 218841 [details]
Patch for pidgin.spec

Patches spec file to depend on avahi-glib-devel, not avahi-devel. The former
depends on the latter, and supplies the avahi-glib headers needed to build the
Bonjour plugin
Comment 6 Michel Alexandre Salim 2007-10-07 14:46:45 EDT
I just did a scratch build and this time it does include the bonjour plugin:

$ rpm -q --requires libpurple | grep avahi
libavahi-client.so.3()(64bit)  
libavahi-common.so.3()(64bit)  
libavahi-glib.so.1()(64bit)

http://koji.fedoraproject.org/koji/taskinfo?taskID=185999
Comment 7 James Gregory 2007-10-07 14:59:40 EDT
Sounds good. Any idea when the new release will be available for Fedora 7?
Comment 8 Michel Alexandre Salim 2007-10-08 15:44:32 EDT
Warren is the maintainer, so it will have to wait until he committed the fix.
After that, then a week or so of the package sitting in the testing repository,
and then it's pushed to -stable.

I believe 2.2.1 is considered a security release, and that's why it landed in
updates without much testing. Sorry about that.
Comment 9 Michel Alexandre Salim 2007-10-08 15:49:28 EDT
Update's been built, but not pushed through the Update System yet (Warren?)

James, if you want to get a head-start, you can download the new packages here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=20414

Comment 10 James Gregory 2007-10-08 18:17:47 EDT
Cheers for that Michel. I've just updated Pidgin and Bonjour seems to be working
now (I can't actually test it at present, but it is showing up properly on the
Accounts list).
Comment 11 Oliver Cole 2007-10-20 20:27:27 EDT
I've updated to those packages. Bonjour was present in the account type list,
and I can see people online. Thanks.

Note You need to log in before you can comment on or make changes to this bug.