Bug 32026 - Redhat 7.1 RC2 (QA0309) display "Kernel Panic" message at the end of installation with RIB board installed on the server.
Redhat 7.1 RC2 (QA0309) display "Kernel Panic" message at the end of installa...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-16 15:09 EST by Bryan Leopard
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 15:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Leopard 2001-03-16 15:09:05 EST
H/W: DL320 (SCSI)
RIB board installed on PCI slot (only 1 PCI slot on server)

S/W:  RH 7.1 RC2 (QA0309)

Steps to duplicate issue:

1.  Installed RIB board to server's PCI slot
2.  Redhat 7.1 RC 2 install 
3.  Complete the installation
4.  Prompt to create boot disk, eject installation CD and attemp to reboot.
4.  Display message:

rebooting system
Oops:  0000
CPU:	0
EIP:	0010:[<940f0000>]
EFLAGS:	00010286
eax:00000000	ebx:c8c4e924	ecx:e36af65c	edx:00000000
esi:00000000	edi:00000001	ebp:bffffec8	esp:c7ff7e90
ds:0018	es:0018	ss:0018

Process linuxrc (pid:8, stackpage=c7ff7000)
Stack: c011b2dd  c8c4e924  00000001 00000000 c7ff6000 00000000  00000072   
c011b5e2

Code: Bad EIP value
VFS: Cannot open root device"" or 08:41
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:41

Workaround:  
1)  Ignore the message, power off the server then power back on> seems to 
work fine.
or
2)  Install Redhat 7.1 RC2 WITHOUT the RIB board.
Comment 1 Bryan Leopard 2001-04-06 12:28:14 EDT
The problem seems to be coming from the megaraid driver in the kernel.  It 
looks at the Compaq RIB board and thinks it is a storage controller.
Comment 2 Arjan van de Ven 2001-04-06 12:30:15 EDT
Recent kudzu's should prevent the megaraid driver from loading in this case....
Is there any way to verify that this actually works ?
Comment 3 Bryan Leopard 2001-04-06 15:34:33 EDT
It works with QA0404 > no longer display kernel panic after installation.   Did 
not work with QA0401.

Please close this issue.

Note You need to log in before you can comment on or make changes to this bug.