Bug 32077 - separate libs out
Summary: separate libs out
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: compat-libs   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-17 09:05 UTC by Dennis Björklund
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 22:37:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dennis Björklund 2001-03-17 09:05:20 UTC
The package really should be split up in one part with the dynamic libs and
one part with the rest. A lot of programs depend on the libs and ypou can't
upgrade bzip2 in the future because of all these other programs. I now have
0.9.5 installed and would like to install 1.0.1 and I can't.

Also, for fisher it would be good with a bzip0.9.5-lib rpm that just
contains the old libbz.0 and libbz2.so.0.0.0

I guess this is the wrong forum for this kind of bug, but I couldn't find
any better.

The idea of building shared libraries is that you should be able to have
several versions installed. To bad that many redhat rpms stops us from
using the dso's as intended.

Comment 1 Trond Eivind Glomsrxd 2001-03-19 22:03:48 UTC
We should probably add a compat package, with just the shared libraries.

Comment 2 Trond Eivind Glomsrxd 2001-03-21 22:46:48 UTC
(of course, this won't be for the next release - we entered package freeze with
the first beta)

Comment 3 Trond Eivind Glomsrxd 2001-03-30 16:38:59 UTC
The libraries are split off in  bzip2-1.0.1-4, as for adding the old ones to
compat-libs, I'm reassigning.

Comment 4 Jakub Jelinek 2004-10-03 22:37:26 UTC
Certainly compat-libs is not a package that should contain random
other libs.


Note You need to log in before you can comment on or make changes to this bug.