Bug 32078 - Bad: gcc crashes while compiling gnustep-base
Summary: Bad: gcc crashes while compiling gnustep-base
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-17 09:06 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 19:17:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarbal with the GSString.mi produced with -save-temps -v flags from several releases of gcc (42.87 KB, type/bzip2)
2001-03-21 19:13 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-03-17 09:06:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i586)


On a k6-200 system, while trying to complile the gnustep-base package
(www.gnustep.org), there is a segmentation fault.

Reproducible: Always
Steps to Reproduce:
1. get
ftp://ftp.gnustep.org/pub/gnustep/rpms/srpms/gnustep-base-0.9.3-1.src.rpm
2. rpm --rebuild gnustep-base-0.9.3-1.src.rpm
3.
	

Actual Results:  The compilation started, and after several files processed
there was a segmentation fault when reaching the GSString.m file.

Expected Results:  complile to the end!

gcc GSString.m -c  -DGNUSTEP_INSTALL_PREFIX=/usr/GNUstep/System
-DGNUSTEP_TARGET_DIR=\"ix86/linux-gnu\" -DGNUSTEP_TARGET_CPU=\"ix86\"
-DGNUSTEP_TARGET_OS=\"linux-gnu\" -DLIBRARY_COMBO=\"gnu-gnu-gnu-xgps\" 
-DHAVE_ICONV  -DHAVE_LIBXML=0 -Wall -DGNUSTEP -DGNUSTEP_VERSION=
-DGNUSTEP_MAJOR_VERSION= -DGNUSTEP_MINOR_VERSION=
-DGNUSTEP_BASE_LIBRARY=1   -DGNU_RUNTIME=1 -DGNUSTEP_BASE_LIBRARY=1
-D_REENTRANT  -fPIC -DGSWARN -O2 -m486 -fno-strength-reduce -Wno-import
-fgnu-runtime   -I../Headers/gnustep -I../Headers -I./ix86/linux-gnu    -I.
-I/usr/GNUstep/System/Headers -I/usr/GNUstep/System/Headers
-I/root/GNUstep/Library/Headers -I/usr/GNUstep/Local/Library/Headers
-I/usr/GNUstep/Network/Library/Headers
-I/usr/GNUstep/System/Library/Headers
-I/usr/GNUstep/Network/Headers/gnustep -I/root/GNUstep/Headers/gnustep
-I/usr/GNUstep/Local/Headers/gnustep -I/usr/GNUstep/System/Headers/gnustep 
-I/usr/GNUstep/Network/Headers/ix86/linux-gnu
-I/root/GNUstep/Headers/ix86/linux-gnu
-I/usr/GNUstep/Local/Headers/ix86/linux-gnu
-I/usr/GNUstep/System/Headers/ix86/linux-gnu -I/root/GNUstep/Headers
-I/usr/GNUstep/Local/Headers -I/usr/GNUstep/Network/Headers
-I/usr/GNUstep/System/Headers  -o
shared_obj/ix86/linux-gnu/gnu-gnu-gnu-xgps/GSString.o
GSString.m:1769: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
gmake[3]: *** [shared_obj/ix86/linux-gnu/gnu-gnu-gnu-xgps/GSString.o] Error
1
gmake[2]: *** [libgnustep-base.build] Error 2
gmake[1]: *** [libgnustep-base.all.library.variables] Error 2
gmake[1]: Leaving directory
`/usr/src/redhat/BUILD/gnustep-base-0.9.3/Source'
gmake: *** [internal-all] Error 2

Comment 1 Jakub Jelinek 2001-03-21 12:54:08 UTC
Which gcc-g77 rpm do you use (there was one Objective-C GC bug fixed
about a month ago)?
Can you please rerun the above command line with -save-temps -v flags
and post here GSString.mi it creates?

Comment 2 Need Real Name 2001-03-21 19:13:38 UTC
Created attachment 13283 [details]
tarbal with the GSString.mi produced with -save-temps -v flags from several releases of gcc

Comment 3 Need Real Name 2001-03-21 19:17:04 UTC
I have tried  that with gcc-2.96-69 (from redhat updates), gcc-2.96-71 (from
fisher beta version) and gcc-2.96-75 (from wolverine beta version). Of course in
each case I installed all the relevant packages (cpp, gcc, gcc-objc, gcc-c++,
libstc* etc). In all the cases I received a seg. fault while processing the
GSString.m file. The problem was always reproducible! I am attaching the
GSString.tar.gz file which contains 3 files:
GSString.69.mi, GSString.71.mi, GSString.75.mi which were produced by the
corresponding release of gcc. A simple gcc <filename> on my system (RH7.0,
k6/200) reproduces the seg. fault always!

Comment 4 Jakub Jelinek 2001-03-22 09:22:02 UTC
It is the Objective C GC collection bug (implemented_classes not registered
with GC), which is fixed since gcc-objc-2.96-76. I can reproduce it with -75
but cannot with -79, and with -75 it dies in the implemented_classes handling
code.


Note You need to log in before you can comment on or make changes to this bug.