Bug 32103 - Lilo installs broken MBR when
Lilo installs broken MBR when
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-17 16:46 EST by drdoc
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 11:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drdoc 2001-03-17 16:46:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686)


On a Dell 5000e with 10G drive, with WinME & RedHat 6.2 installed, I've
installed RH7.0 respin on a separate partition, sharing only swap and /boot
(/dev/hda2) with the RH6.2 install
 As I have a custom /etc/lilo.conf for 6.2, and intended to add the 7.0
image to that configuration, I chose during install of 7.0 to make a boot
floppy and chose "Do Not Install Lilo". The install finished successfully,
but on reboot I found that the MBR had been overwritten with a bad boot
image. Lilo loaded to the LI_ point. I was able to boot from the RH6.2 boot
floppy, add the 7.0 image to /etc/lilo.conf, run lilo and boot the machine
properly.
  Harddrive configuration, as seen from RH6.2, is as follows:
/dev/hda1	FAT32	/WinME	325 cyl.
/dev/hda2	ext2	/boot	2 cyl.
/dev/hda3	extended
/dev/hda5	ext2	/	375 cyl.
/dev/hda6	ext2	/home	100 cyl.
/dev/hda7	swap		50 cyl.
/dev/hda8	ext2	rh7	300 cyl.

Reproducible: Always
Steps to Reproduce:
1.Install WinXX, RH6.2, leaving unpartitioned space on first drive
2.Install RH7 as separate install, not upgrade
3.Choose "Do Not Install LILO"
4. Reboot

Actual Results:  When booting from harddrive, LILO loads to LI_ and hangs

Expected Results:  As lilo should not have run at all during the 7.0
install, LILO should load normally per RH6.2 configuration.
Comment 1 drdoc 2001-03-17 22:33:43 EST
This error happens anytime I choose not to install lilo during install,
regardless of other OS's present or partitioning. Also reproduced on 2 other
systems.
Comment 2 Michael Fulbright 2001-03-21 14:40:33 EST
Did your old kernel get replaced by the new kernel?

If this happens then LILO will not suceeded because the old kernel is no longer
present.
Comment 3 drdoc 2001-03-22 11:43:46 EST
 No. The old kernel does not get replaced. If I boot to the v6.2 install via
boot floppy and run lilo with the original lilo.conf, I can then boot WinME and
6.2. The intention was that I would add astanza to the v6.2 lilo.conf to boot
the v7.0 install. This also works, after editting lilo.conf.
 The same problem exists if only WinXX or no OS are initially on the machine. RH
7, instead of not installing lilo at all, writes a corrupted MBR.
Comment 4 Brent Fox 2001-04-21 19:06:28 EDT
Can you reproduce this with 7.1?
Comment 5 Brent Fox 2001-04-23 11:43:42 EDT
I am unable to duplicate this with Red Hat Linux 7.1.  Resolving as 'Current
Release'.

Note You need to log in before you can comment on or make changes to this bug.