Bug 321231 - Subject title of the mail generated by yum-updatesd are not very informative
Subject title of the mail generated by yum-updatesd are not very informative
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-updatesd (Show other bugs)
5.0
All Linux
high Severity low
: ---
: ---
Assigned To: James Antill
Karel Srot
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 06:02 EDT by Frank Büttner
Modified: 2012-10-11 04:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 14:34:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2007-10-06 06:02:24 EDT
Description of problem:
When say yum-updatesd to send mails when updates are available, then the subject
field of the resulting mail are not very informative, because it only say: "XXX
Updates Available". When you have many systems, then it will become very
unclear, because you can't see witch system it is, when you get many mails.
It will be much better, when the subject line will called:"[systemname] XXXX
Updates Available"

Version-Release number of selected component (if applicable):
yum-updatesd-3.0.5-1

How reproducible:
every time

Steps to Reproduce:
1. set in the file /etc/yum/yum-updatesd.conf emit_via = email dbus
2. wait for new updates available 
  
Actual results:
You get an mail without the system name in the subject field

Expected results:
That the mail contains the system name in the subject field.

Additional info:
I have read the man page, but I can't find an option for that.
Comment 1 RHEL Product and Program Management 2007-10-16 09:44:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 RHEL Product and Program Management 2008-02-04 17:35:21 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 5 James Antill 2008-02-04 20:30:26 EST
 Again didn't want to do that.
Comment 7 Ken Reilly 2008-02-06 10:22:48 EST
After reviewing the stats with James on 5-February-2008, given the fix isn't
upstream yet but is expected to be resolved in Fedora9 GA, I've stripped the
rhel-5.2.0 flags and set the rhel-5.3.0 and pm_ack flags to '?'. 
Comment 8 RHEL Product and Program Management 2008-06-02 16:30:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 RHEL Product and Program Management 2009-03-26 13:02:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 RHEL Product and Program Management 2012-04-02 06:30:57 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 13 Karel Srot 2012-06-28 04:08:36 EDT
Hi James,
with yum-updatesd from RHEL5.8 the subject already contain the hostname.
Seems there is nothing to do for RHEL5.9. Could you please confirm?

# rpm -q yum-updatesd
yum-updatesd-0.9-2.el5



# cat /var/spool/mail/bz321231user
---------8<-------------8<------------8<---------
Subject: yum: 1 Updates Available (on XXX.YYY.redhat.com) 
From: bz321231updatesd@XXX.YYY.redhat.com">bz321231updatesd@XXX.YYY.redhat.com
To: bz321231user@XXX.YYY.redhat.com">bz321231user@XXX.YYY.redhat.com
Date: Thu, 28 Jun 2012 07:59:21 GMT

Hi,
This is the automatic update system on XXX.YYY.redhat.com.

There are 1 package updates available. Please run the system updater.

Packages available for update:

    bz321231pkg                   

Thank You,
Your Computer
---------8<-------------8<------------8<---------
Comment 14 James Antill 2012-06-29 14:34:16 EDT
 Yeh, the yum-updatesd I see in git for 5.9 has this subject for all emails it sends:

        msg['Subject'] = "yum: %s (on %s) " % (subject, socket.gethostname())

...and AFAICS this hasn't changed since RHEL-5.0. So I'm a bit confused.

Note You need to log in before you can comment on or make changes to this bug.