Bug 321481 - yum-utils - "maximum recursion depth exceeded" in package-cleanup
yum-utils - "maximum recursion depth exceeded" in package-cleanup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 13:43 EDT by Michal Jaegermann
Modified: 2014-01-21 01:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 09:07:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-10-06 13:43:39 EDT
Description of problem:

With all current updates commands like 'package-cleanup --problems'
or 'package-cleanup --dupes' end up with the following:

Traceback (most recent call last):
  File "/usr/bin/package-cleanup", line 402, in <module>
    main()
  File "/usr/bin/package-cleanup", line 365, in main
    my = initYum(opts)
  File "/usr/bin/package-cleanup", line 48, in initYum
    my.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
   return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
   pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 397, in _getSacks
    self.costExcludePackages()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 628, in
costExcludePackages
    for po in self.pkgSack:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
   pkgSack = property(fget=lambda self: self._getSacks(),
.....
(120K of the same skipped)
.....
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 526, in <lambda>
   pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 220, in populateSack
    myrepos = self.listEnabled()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 153, in listEnabled
   if repo.isEnabled():
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 281, in isEnabled
    enabled = self.getAttribute('enabled')
RuntimeError: maximum recursion depth exceeded

'package-cleanup --help' or 'package-cleanup --orphans' works without
any recursion surprises.

Version-Release number of selected component (if applicable):
yum-utils-1.1.7-1.fc8
yum-3.2.6-1.fc8

How reproducible:
always
Comment 1 Seth Vidal 2007-10-08 09:07:37 EDT
this is fixed in git in yum, currently. A patch will be included for fedora today.

thanks
Comment 2 Edouard PELLERIN 2009-04-13 07:26:17 EDT
I have the same error with yum-utils 1.1.19/yum 3.2.21 on an up to date F10 installation. Is this version not patched ? It was previously working and I don't see what could have changed since last time.
Comment 3 seth vidal 2009-04-13 11:15:29 EDT
you get this exact error? Can you post the complete output you're seeing?
Comment 4 Edouard PELLERIN 2009-04-13 11:54:52 EDT
The "Runtime Error" was the same. After looking in details, I saw an impressive number of lines with :
"0 packages excluded due to repository protections
Reading version lock configuration"
I disabled the versionlock plugin, and it was working again. Should I file a new bug for versionlock ?
Comment 5 seth vidal 2009-04-13 12:01:01 EDT
Did you receive this error when running package-cleanup or something else?

In either case what verson of yum-versionlock do you have installed?
Comment 6 Edouard PELLERIN 2009-04-13 12:04:27 EDT
I got the error when running "package-cleanup --leaves"
The version of yum-lockversion is 1.1.19

Note You need to log in before you can comment on or make changes to this bug.