Bug 321591 - Restart hangs on Toshiba Qosmio F20
Restart hangs on Toshiba Qosmio F20
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 16:17 EDT by Peter H. Jones
Modified: 2008-05-22 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 00:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2007-10-06 16:17:28 EDT
Description of problem:
Restart hangs on Qosmio F20.

Version-Release number of selected component (if applicable):
kernel-2.6.23-0.217.rc9.git1.fc8

How reproducible:
Always

Steps to Reproduce:
1. From "System" menu, select "Log Out" and "Restart".

  
Actual results:
System shuts down.
A "TIMER INTERRUPT ERROR" message appears at the top of the screen
Grub menu appears
System starts to boot in Fedora, but hangs, always at the same place. I will
post the last lines when I try the Restart again. I have to shut down by holding
the Power button, then I can restart normally.

Expected results:
Restart without any manual intervention

Additional info:
Restart works fine with other OS's, such as Knoppix 5.1.1, or Windows XP.
Comment 1 Peter H. Jones 2007-10-06 16:26:23 EDT
Last lines appearing on screen correspond to the following in the following
normal dmesg:

     98 virtual kernel memory layout:
     99     fixmap  : 0xffc53000 - 0xfffff000   (3760 kB)
    100     pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
    101     vmalloc : 0xf8800000 - 0xff7fe000   ( 111 MB)
    102     lowmem  : 0xc0000000 - 0xf8000000   ( 896 MB)
    103       .init : 0xc075f000 - 0xc07ed000   ( 568 kB)
    104       .data : 0xc0636c47 - 0xc0759a44   (1163 kB)
    105       .text : 0xc0400000 - 0xc0636c47   (2267 kB)
    106 Checking if this processor honours the WP bit even in supervisor mode... Ok.
    107 SLUB: Genslabs=22, HWalign=64, Order=0-1, MinObjects=4, CPUs=1, Nodes=1

Next lines in a normal dmesg are:
    108 Calibrating delay using timer specific routine.. 3993.16 BogoMIPS
(lpj=1996581)
    109 Security Framework v1.0.0 initialized
    110 SELinux:  Initializing.
    111 SELinux:  Starting in permissive mode
 
Presumably the system is hanging in the "Calibrating delay" line because of the
TIMER INTERRUPT ERROR.
Comment 2 Chuck Ebbert 2007-10-08 15:45:31 EDT
Can you try the workarounds in section "System hangs on reboot":

http://fedoraproject.org/wiki/KernelCommonProblems

Comment 3 Peter H. Jones 2007-10-09 10:31:07 EDT
Tried reboot=b, w, and b,w in grub.conf. System always hangs. This also happens
in  mode 3 and 1 (i.e. I have added "1 reboot=r,w" to the end of the "kernel" line.
in grub.conf

Will work down the Common Problems in more detail and report later.
Comment 4 Peter H. Jones 2007-10-09 12:04:25 EDT
Adding the following parameters makes the reboot sequence work:
nohz=off highres=off .

So, the complete grub entry I am using is:
title Fedora (2.6.23-0.224.rc9.git6.fc8)
        root (hd0,1)
        kernel /vmlinuz-2.6.23-0.224.rc9.git6.fc8 ro root=LABEL=/ rhgb nohz=off
highres=off
        initrd /initrd-2.6.23-0.224.rc9.git6.fc8.img

As you can see, I have updated the kernel since first reporting this bug.
Comment 5 Christopher Brown 2008-02-03 17:39:18 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 6 Peter H. Jones 2008-02-04 10:49:37 EST
Still have the bug with kernel-2.6.23.14-107.fc8 .
Comment 7 Christopher Brown 2008-02-04 12:49:29 EST
Okay, thanks for the update. It might be worth testing with 2.6.24 when it
arrives and updating this bug.
Comment 8 Peter H. Jones 2008-03-14 22:32:59 EDT
Tried with kernel-2.6.24.3-12.fc8 that has just appeared. Looks ok, but I'd like
to test when bug https://bugzilla.redhat.com/show_bug.cgi?id=436589#c4 is
resolved, as losing the network is a show stopper for me.
Comment 9 Peter H. Jones 2008-03-17 01:15:33 EDT
Was able to warm-boot from kernel-2.6.23.15-137.fc8 to kernel-2.6.24.3-34.fc8
and within the latter, deleting the extra parameters I had added to the the line
in comment #4. Looks good, but networking must be started manually with the new
kernel.
Comment 10 Peter H. Jones 2008-05-22 00:15:19 EDT
Works with kernel 2.6.25.3-18.fc9.i686 .

Note You need to log in before you can comment on or make changes to this bug.