This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 321921 - syncmaster -- intel (out of range) - i810 (ok)
syncmaster -- intel (out of range) - i810 (ok)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 06:18 EDT by shrek-m
Modified: 2008-01-15 09:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 09:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf "intel" and "i810" (814 bytes, text/plain)
2007-10-07 06:18 EDT, shrek-m
no flags Details
log - intel - out of range (66.02 KB, text/plain)
2007-10-07 06:20 EDT, shrek-m
no flags Details
log - i810 - ok (67.37 KB, text/plain)
2007-10-07 06:21 EDT, shrek-m
no flags Details
Xorg.0.log - intel - without xorg.conf (25.88 KB, text/plain)
2007-11-14 13:47 EST, shrek-m
no flags Details
Xorg.0.log - vesa (46.69 KB, text/plain)
2007-11-14 13:49 EST, shrek-m
no flags Details
Xorg.0.log - rhgb - intel - without xorg.conf - monitor goes off (20.85 KB, text/plain)
2008-01-15 09:45 EST, shrek-m
no flags Details

  None (edit)
Description shrek-m 2007-10-07 06:18:52 EDT
Description of problem:
the "syncmaster 215 tw" does not work with the "intel" driver
"not optimum mode - recommended mode 1680x1050 60Hz"

"i810" driver is ok.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.1-4.fc8


How reproducible:
always

Steps to Reproduce:
1. system-config-dislpay --reconfig

  
Actual results:
"intel" = no display
manual change to "i810" = ok
Comment 1 shrek-m 2007-10-07 06:18:52 EDT
Created attachment 218631 [details]
xorg.conf "intel" and "i810"
Comment 2 shrek-m 2007-10-07 06:20:52 EDT
Created attachment 218641 [details]
log - intel - out of range
Comment 3 shrek-m 2007-10-07 06:21:27 EDT
Created attachment 218651 [details]
log - i810 - ok
Comment 4 Dave Airlie 2007-10-10 21:14:13 EDT
can you retry with latest rawhide xorg server? I think you were hitting a bug in
the mode code..
Comment 5 shrek-m 2007-10-11 09:29:21 EDT
afaik it is the latest xorg-server.

lftp download.fedora.redhat.com:/>
ls pub/fedora/linux/development/i386/os/Packages/xorg-x11-server-Xorg*
-rw-r--r--    1 ftp      ftp       3040716 Oct 05 16:46
xorg-x11-server-Xorg-1.3.0.0-29.fc8.i386.rpm


# grep xorg /var/log/yum.log
Okt 06 12:42:22 Updated: xorg-x11-server-Xorg - 1.3.0.0-28.fc8.i386
Okt 06 12:42:24 Updated: xorg-x11-drv-i810 - 2.1.1-4.fc8.i386
Okt 06 12:42:25 Updated: xorg-x11-drv-ati - 6.7.194-3.fc8.i386
Okt 06 22:43:28 Updated: xorg-x11-server-Xorg - 1.3.0.0-29.fc8.i386
Oct 08 14:58:57 Installed: xorg-x11-server-Xdmx - 1.3.0.0-29.fc8.i386
Okt 08 15:10:31 Updated: xorg-x11-drv-ati - 6.7.195-1.fc8.i386
[root@localhost ~]# rpm -qa xorg-x11-server\*
xorg-x11-server-Xorg-1.3.0.0-29.fc8
xorg-x11-server-Xdmx-1.3.0.0-29.fc8
xorg-x11-server-utils-7.3-1.fc8


# yum update
Setting up Update Process
No Packages marked for Update
Comment 6 shrek-m 2007-10-25 09:52:36 EDT
still the same problem, i810 is ok.

# grep xorg /var/log/yum.log
Okt 18 16:48:52 Updated: xorg-x11-server-Xdmx - 1.3.0.0-33.fc8.i386
Okt 18 16:49:56 Updated: xorg-x11-server-Xorg - 1.3.0.0-33.fc8.i386
Okt 18 16:50:11 Updated: xorg-x11-drv-mouse - 1.2.3-1.fc8.i386
Okt 18 16:50:12 Updated: xorg-x11-drv-i810 - 2.1.1-7.fc8.i386
Okt 24 20:40:29 Installed: xorg-x11-server-Xnest - 1.3.0.0-33.fc8.i386
Comment 7 shrek-m 2007-11-13 16:14:13 EST
still the same problem in rawhide:

# date -u
Di 13. Nov 21:11:09 UTC 2007


# grep xorg /var/log/yum.log
Nov 10 12:19:03 Updated: xorg-x11-drv-ati - 6.7.195-4.fc9.i386
Nov 10 13:18:03 Updated: xorg-x11-drv-mouse - 1.2.3-2.fc9.i386

# rpm -qa xorg-x11-serv\* xorg-x11-drv-i\* | sort
xorg-x11-drv-i128-1.2.1-1.fc8
xorg-x11-drv-i740-1.1.0-5.fc8
xorg-x11-drv-i810-2.1.1-7.fc8
xorg-x11-server-utils-7.3-1.fc8
xorg-x11-server-Xdmx-1.3.0.0-33.fc8
xorg-x11-server-Xnest-1.3.0.0-33.fc8
xorg-x11-server-Xorg-1.3.0.0-33.fc8
Comment 8 shrek-m 2007-11-14 08:51:23 EST
what i expected ;-)

- the "i810" driver is gone away.

- at least "vesa" let me login at 1024x768

- "intel" does not work == "out of range"
even a vt-switch is no longer possible, the monitor goes absolutely black
without any data.
via remote-ssh-login i have to change the driver to "vesa" and 'init 3; init 5'



# grep xorg /var/log/yum.log | sort
Nov 10 12:19:03 Updated: xorg-x11-drv-ati - 6.7.195-4.fc9.i386
Nov 10 13:18:03 Updated: xorg-x11-drv-mouse - 1.2.3-2.fc9.i386
Nov 14 14:03:24 Installed: xorg-x11-server-common - 1.4.99.1-0.10.fc9.i386
Nov 14 14:08:42 Updated: xorg-x11-server-Xnest - 1.4.99.1-0.10.fc9.i386
Nov 14 14:08:43 Updated: xorg-x11-server-Xdmx - 1.4.99.1-0.10.fc9.i386
Nov 14 14:11:07 Updated: xorg-x11-drv-keyboard - 1.2.2-3.fc9.i386
Nov 14 14:11:10 Updated: xorg-x11-drv-vesa - 1.3.0-11.20071113.fc9.i386
Nov 14 14:11:11 Updated: xorg-x11-drv-void - 1.1.1-7.fc9.i386
Nov 14 14:11:14 Updated: xorg-x11-drv-mouse - 1.2.3-3.fc9.i386
Nov 14 14:11:14 Updated: xorg-x11-server-Xorg - 1.4.99.1-0.10.fc9.i386
Nov 14 14:11:15 Updated: xorg-x11-drv-fbdev - 0.3.1-4.20071113.fc9.i386
Nov 14 14:11:15 Updated: xorg-x11-drv-i810 - 2.1.99-1.fc9.i386
Nov 14 14:11:16 Updated: xorg-x11-drv-ati - 6.7.195-5.fc9.i386
Nov 14 14:11:17 Updated: xorg-x11-drv-dummy - 0.2.0-6.fc9.i386
Nov 14 14:11:17 Updated: xorg-x11-drv-nouveau - 2.1.6-2.fc9.i386
Nov 14 14:11:18 Updated: xorg-x11-drv-nv - 2.1.6-2.fc9.i386
Comment 9 shrek-m 2007-11-14 13:47:52 EST
Created attachment 258541 [details]
Xorg.0.log - intel - without xorg.conf

intel does not work
the last display before "not optimum mode" is the gdm-logon-screen
Comment 10 shrek-m 2007-11-14 13:49:51 EST
Created attachment 258551 [details]
Xorg.0.log - vesa

with "vesa" in the xorg.conf i can logon
Comment 11 Jesse Barnes 2008-01-10 18:23:55 EST
We made some clock changes upstream recently (for the 2.2 release iirc, but 
they may just be in master), can you retest with that and see if this still 
happens?
Comment 12 shrek-m 2008-01-15 09:32:02 EST
xorg-x11-drv-i810-2.2.0-3.fc9  without xorg.conf

thanks, seems to be ok now without rhgb == "norhgb"
with "rhgb", no chance because the intel-driver can not switch the ttys.

closed as upstream.


--------
fyi:
playing with "HorizSync" in the monitor-section solved the problem in other
distris, eg.:

centos:
HorizSync    31.5 - 67.0
VertRefresh  50.0 - 75.0

debian:
HorizSync       28-84
VertRefresh     43-60
Comment 13 shrek-m 2008-01-15 09:45:31 EST
Created attachment 291715 [details]
Xorg.0.log - rhgb - intel - without xorg.conf - monitor goes off

the Xorg.log
no xorg.conf
with rhgb no chance.
no tty-switch is possible, the monitor goes off while booting

if you can find some usefull info, take it.

Note You need to log in before you can comment on or make changes to this bug.