Bug 321941 - gpodder failed to start
gpodder failed to start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpodder (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 06:38 EDT by Thorsten Scherf
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 18:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2007-10-07 06:38:54 EDT
Description of problem:

[tscherf@tiffy ~]$ gpodder 
Traceback (most recent call last):
  File "/usr/bin/gpodder", line 145, in <module>
    sys.exit( main())
  File "/usr/bin/gpodder", line 101, in main
    from gpodder import console
  File "/usr/lib/python2.5/site-packages/gpodder/console.py", line 29, in <module>
    from libgpodder import gPodderChannelReader
  File "/usr/lib/python2.5/site-packages/gpodder/libgpodder.py", line 39, in
<module>
    from xml.sax.saxutils import DefaultHandler
ImportError: cannot import name DefaultHandler
[tscherf@tiffy ~]$ 

this happened with latest rawhide packages.


Version-Release number of selected component (if applicable):
gpodder-0.9.5-1.fc8

How reproducible:
start podder

Steps to Reproduce:
1.start gpodder
2.
3.
  
Actual results:
it fails to start up

Expected results:
it starts up

Additional info:
Comment 1 Jef Spaleta 2007-10-07 21:40:36 EDT
hmm it seems python 2.5.1 dropped the DefaultHandler definition.
And it looks like the newest gpodder 0.10 no longer uses DefaultHandler.
I'm going to spin up some locally built test packages of gpodder 0.10 for F7 and
development. I'll post again with the location of the binaries for 0.10 once I
get them built 


-jef
Comment 2 Jef Spaleta 2007-10-08 00:36:21 EDT
Okay can you please test this package:
http://jspaleta.fedorapeople.org/Fedora/gpodder-0.10/devel/gpodder-0.10.0-1.fc8.noarch.rpm

I've also rebuilt this against F7:
http://jspaleta.fedorapeople.org/Fedora/gpodder-0.10/F7/gpodder-0.10.0-1.fc7.noarch.rpm

I've done a shallow test of the F7 build locally.  Please test the build meant
for devel and see if it starts up as expected.

-jef
Comment 3 Jef Spaleta 2007-10-09 18:40:26 EDT
0.10 now available in development. I've had at least one additional tester
confirm that the application properly starts up. Closing ticket.

Note You need to log in before you can comment on or make changes to this bug.