Bug 32225 - rpm somtimes hangs while processing man-pages
Summary: rpm somtimes hangs while processing man-pages
Status: CLOSED DUPLICATE of bug 14844
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-19 14:26 UTC by M. Goppold
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 14:27:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description M. Goppold 2001-03-19 14:26:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; IRIX 6.3 IP32)


rpm -ba specfile sometimes hangs in /usr/lib/rpm/brp-compress
...
./mkinstalldirs /tmp/package-root/usr/man/man8
installing package.8 /tmp/package-root/usr/man/man8
+ /usr/lib/rpm/brp-compress

Reproducible: Sometimes
Steps to Reproduce:
1.rpm -ba fping.spec
2.
3.
	

rpm --version: RPM Version 4.0

I've solved this problem using:
--- brp-compress_orig   Mon Mar 19 15:24:26 2001
+++ brp-compress        Mon Mar 19 14:22:37 2001
@@ -8,7 +8,7 @@
 cd $RPM_BUILD_ROOT
 
 # Compress man pages
-COMPRESS="gzip -9"
+COMPRESS="gzip -f -9"
 COMPRESS_EXT=.gz
 
 for d in ./usr/man/man* ./usr/man/*/man* ./usr/info \

Comment 1 Jeff Johnson 2001-03-19 14:40:22 UTC

*** This bug has been marked as a duplicate of 14844 ***


Note You need to log in before you can comment on or make changes to this bug.