Bug 322461 - LabPlot places its menu entry in Other category (Gnome)
LabPlot places its menu entry in Other category (Gnome)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: LabPlot (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 16:15 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-07 17:06:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-10-07 16:15:19 EDT
Description of problem:
I think the entry belongs to Science.

Version-Release number of selected component (if applicable):
1.5.1.6-4.fc8

How reproducible:
always

Steps to Reproduce:
1. yum install LabPlot
2. Login to gnome desktop
  
Actual results:
Icon is in Other menu

Expected results:
Icon is in Science menu

Additional info:
I'm not sure, but I think this was fine under f7
Comment 1 Chitlesh GOORAH 2007-10-07 17:06:20 EDT
It was recently changed from "Science;Engineering" or "Science;Electronics" as 
stated by
http://standards.freedesktop.org/menu-spec/latest/apa.html

Additional Category - Description                        - Related Categories
Electronics  -  Electronics software, e.g. a circuit designer    - [ ]
Engineering  -  Engineering software, e.g. CAD programs    - [ ]

  [Desktop Entry]
  Categories=Science;Electronics; or  Categories=Science;Engineering;

Since those packages are not meant for "Education" (but instead Engineering),
the category "Education" is inappropriate.

However, on :
* KDE : the applications are properly displayed on a menu "Science &
Math", (octave uses it as well)
* gnome : the applications are displayed on a menu "Other".

gnome puts categories for which it does not have an appropriate menu
to other and since there isn't one for science or electronics.

I've discussed this issue with the freedesktop, some fedora guys and gnome 
guys on their respective channels, and they are OK with having those tools on 
the "Other" menu of gnome.

There will be a better solution with the upcoming version of gnome and 
freedesktop policies.

Thus I'm closing this bug as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.