Bug 322631 - Record-only usb audio device not showing under volume control
Record-only usb audio device not showing under volume control
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 21:52 EDT by David Campbell
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-18 23:39:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of hal-device-manager showing alsa control device (96.83 KB, image/png)
2007-10-08 06:32 EDT, David Campbell
no flags Details

  None (edit)
Description David Campbell 2007-10-07 21:52:49 EDT
Description of problem:

I have a TV tuner with an audio in capability, but even though it does appear in
hal-device-manager with both alsa and oss control devices, and does appear under
sound preferences under Audio Conferencing - sound capture as "USB Audio" (which
is a poor name in my view given that the device does have a name provided via
usb), it does not appear under volume control in any mixers at all, and is not
listed under File/Change Device.

I would expect the input volume to be configurable via volume control.

Version-Release number of selected component (if applicable):

gnome-media-2.18.0-3.fc7

How reproducible:

Always
Comment 1 Bastien Nocera 2007-10-08 06:01:27 EDT
> "USB Audio" (which is a poor name in my view given that the device does have a
> name provided via usb)

ALSA provides the device's name. Check the output of /proc/asound/cards to see
what name is given.

Could you please give the output of "amixer -c X" where X is the card number for
the device?
Comment 2 David Campbell 2007-10-08 06:09:20 EDT
I trust this is the info you need:

[root@Vigor11 ~]# cat /proc/asound/cards
 0 [ICH5           ]: ICH4 - Intel ICH5
                      Intel ICH5 with ALC650F at irq 17
 1 [default        ]: USB-Audio - TV USB2.0  
                      AVerMedia  TV USB2.0   at usb-0000:00:1d.7-5, high speed
 2 [Modem          ]: ICH-MODEM - Intel ICH5 Modem
                      Intel ICH5 Modem at irq 17
[root@Vigor11 ~]# amixer -c 1
[root@Vigor11 ~]#
Comment 3 Bastien Nocera 2007-10-08 06:18:21 EDT
Your device doesn't have any ALSA controls.
Comment 4 David Campbell 2007-10-08 06:32:34 EDT
Created attachment 219601 [details]
screen shot of hal-device-manager showing alsa control device

What do you make of the output of hal-device-manager then as I attach?
Comment 5 Bastien Nocera 2007-10-08 06:40:37 EDT
(In reply to comment #4)
> Created an attachment (id=219601) [edit]
> screen shot of hal-device-manager showing alsa control device
> 
> What do you make of the output of hal-device-manager then as I attach?

Looks like ALSA only handles one of the interfaces on the device (probably the
Control Device), and not the Capture one. Looks like a driver bug.

Note You need to log in before you can comment on or make changes to this bug.