Bug 322641 - Usb audio device with playback and record shows only playback volume control tab in volume control
Usb audio device with playback and record shows only playback volume control ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 22:06 EDT by David Campbell
Modified: 2008-02-25 10:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 10:14:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the screenshot of the extra tracks as you request (46.59 KB, image/png)
2007-10-08 06:26 EDT, David Campbell
no flags Details
screen shot of volume control viewing USB phone (playback only) (366.72 KB, image/png)
2007-10-08 06:28 EDT, David Campbell
no flags Details
screen shot of hal-device-manager showing alsa capture device (89.91 KB, image/png)
2007-10-08 06:46 EDT, David Campbell
no flags Details
the corrected screenshow of the extra tracks as you request (9.84 KB, image/png)
2007-10-08 06:55 EDT, David Campbell
no flags Details
scsconfig.log attached as requested (53.68 KB, text/plain)
2007-12-07 12:51 EST, David Campbell
no flags Details

  None (edit)
Description David Campbell 2007-10-07 22:06:58 EDT
Description of problem:

If I plug in a usb phone (and it is working fine), it gets listed under
File/Change Device, but even though the USB phone has both input and output of
audio, only a playback volume control is shown.  There is no recording tab at
all provided.

I would expect both playback and recording to be configurable.

Version-Release number of selected component (if applicable):

gnome-media-2.18.0-3.fc7

How reproducible:

Always
Comment 1 Bastien Nocera 2007-10-08 05:57:50 EDT
Are the extra tracks available for selection in the preferences? (could you
please get a screenshot of the dialogue).

Please also attach the output of "amixer -c X" (where X is the card number) for
this device.
Comment 2 David Campbell 2007-10-08 06:26:16 EDT
Created attachment 219581 [details]
the screenshot of the extra tracks as you request

[root@Vigor11 ~]# cat /proc/asound/cards
 0 [ICH5	   ]: ICH4 - Intel ICH5
		      Intel ICH5 with ALC650F at irq 17
 1 [default	   ]: USB-Audio - TV USB2.0  
		      AVerMedia  TV USB2.0   at usb-0000:00:1d.7-5, high speed
 2 [Modem	   ]: ICH-MODEM - Intel ICH5 Modem
		      Intel ICH5 Modem at irq 17
 3 [Phone	   ]: USB-Audio - USB Phone
		      Elan USB Phone at usb-0000:00:1d.1-1, full speed

[root@Vigor11 ~]# amixer -c 3
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 19
  Mono:
  Front Left: Playback 19 [100%] [0.00dB] [on]
  Front Right: Playback 19 [100%] [0.00dB] [on]

There's nothing device-specific in the extra tracks available for selection in
the preferences.

I attach the window as you requested though it wouldn't all fit.  The remaining
bottom entries are:
Channel Mode
Duplication Front
Exchange Centre/LFE
External Amplifier
Swap Surround Slot
Comment 3 David Campbell 2007-10-08 06:28:06 EDT
Created attachment 219591 [details]
screen shot of volume control viewing USB phone (playback only)
Comment 4 Bastien Nocera 2007-10-08 06:38:05 EDT
The extra tracks in the prefs are supposed to be device specific, so it's
possible that gnome-volume-control didn't update the track list when changing
the device. Could you file another bug about this?

Finally, your device doesn't have input support, it only has one output track,
and no input tracks.
Comment 5 David Campbell 2007-10-08 06:46:01 EDT
Created attachment 219611 [details]
screen shot of hal-device-manager showing alsa capture device

I don't understand how you can say that this device has no input support.  This
is a usb phone with input and output that does actually work on this very
linux, and  hal-device-manager can see the ALSA capture device (see my
attachment), and if I run audio programs on linux, the USB phone actually does
work for both input and output audio.
Comment 6 Bastien Nocera 2007-10-08 06:52:30 EDT
(In reply to comment #5)
> Created an attachment (id=219611) [edit]
> screen shot of hal-device-manager showing alsa capture device
> 
> I don't understand how you can say that this device has no input support.  This
> is a usb phone with input and output that does actually work on this very
> linux, and  hal-device-manager can see the ALSA capture device (see my
> attachment), and if I run audio programs on linux, the USB phone actually does
> work for both input and output audio.

It might do, but ALSA doesn't know about the extra capture interface, so doesn't
show any capture tracks. You can see that for yourself in the output of amixer.

Most likely a driver bug. Martin will give you a hand debugging that, as there's
nothing gnome-volume-control can do if ALSA doesn't present the extra tracks.
Comment 7 David Campbell 2007-10-08 06:55:13 EDT
Created attachment 219631 [details]
the corrected screenshow of the extra tracks as you request

Regarding your request to file a bug on gnome-volume-control, it looks like I
sent you the wrong screen shot - it seems no need to file an additional report.
Comment 8 Bastien Nocera 2007-10-08 07:01:00 EDT
(In reply to comment #7)
> Created an attachment (id=219631) [edit]
> the corrected screenshow of the extra tracks as you request
> 
> Regarding your request to file a bug on gnome-volume-control, it looks like I
> sent you the wrong screen shot - it seems no need to file an additional report.

Great, I wasn't looking forward to debugging that one :)
Comment 9 Martin Stransky 2007-12-07 07:06:39 EST
Can you please run system-config-soundcard, generate a log (/root/scsconfig.log)
and attach it here?
Comment 10 David Campbell 2007-12-07 12:49:35 EST
I've upgraded to f8, and problem is still apparent, so switching this report to
be against f8.  I'm using gnome-media-2.20.1-3.fc8 and gnome-volume-control 2.20.1

Comment 11 David Campbell 2007-12-07 12:51:03 EST
Created attachment 281411 [details]
scsconfig.log attached as requested
Comment 12 David Campbell 2007-12-07 13:21:21 EST
Although not part of this specific report, this problem might be part of a
larger picture of fairly serious audio brokenness.

For example, I find that Volume Control even for my system's primary "Intel ICH5
(Alsa mixer)" audio device shows "Line-in" and "Microphone" under the "Playback"
tab, and there is no "Recording" tab at all there.  Weird!!  I can raise another
problem report for this matter if you like...

Also, if I select the "Realtek ALC650F (OSS Mixer)" device, the "Playback" tab
shows only "Speaker", and a "Recording" tab does exist showing Volume, Line-in,
Microphone, and CD.

I also draw your attention to https://bugzilla.redhat.com/show_bug.cgi?id=381691
where if the usb audio device is connected at boot time, the kernel inserts the
usb audio device at index 0 even when a different pci audio device is specified
at index 0 in /etc/modprobe.conf

Comment 13 Martin Stransky 2008-02-25 10:14:46 EST
If you have a problem with mixer or card order, please file a new bug against
the pulseaudio component.

If you have a problem with recording (the record channels are not shown in
alsamixer (command line utility)), please file a bug against kernel (it's a
problem in drivers).

Note You need to log in before you can comment on or make changes to this bug.