Bug 322721 - entities missing from Common_Content files
entities missing from Common_Content files
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Michael Hideo
: Documentation, Translation
: 327291 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 01:03 EDT by David O'Brien
Modified: 2010-11-23 22:59 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 17:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2007-10-08 01:03:22 EDT
Description of problem:

Feedback.xml in Common_Content does not merge entities files.

Version-Release number of selected component (if applicable):
Name:           documentation-devel
Summary:        Common files and scripts for building Red Hat documentation
Version:        0.22


How reproducible:
Always

Steps to Reproduce:
1. Specify an entity in the .ent file for a book
2. Use that entity in Feedback.xml in Common_Content
3. Build the book (make sure the book doesn't point to a local feedback.xml
  
Actual results:
tmp/en-US/xml/Common_Content/Feedback.xml:17: parser error : Entity 'BOOKID' not
defined

Expected results:
&BOOKID; should be resolved


Additional info:
Comment 1 Jeff Fearn 2007-10-08 21:43:28 EDT
Added logic to detect local ent file and insert it in to common xml files at
build time.

This fix will be available in version 0.23

Two things must happen before I spin 0.23.

1: You should update the common xml files to suite your purpose.
2: The translations will then need to be updated.

Let me know when 1 has finished and I'll walk you through how to get number 2 done.

Cheers, Jeff.
Comment 2 Jeff Fearn 2007-10-10 01:05:31 EDT
Hi Chester, this package needs to be translated.

Current translation status:

https://engineering.redhat.com/docbot/Reports/documentation-devel/HEAD/index.html

CVS Location:
cvs-ecs
cvs co GUI_Strings/documentation-devel

Please reassign this ticket to me when all the translations are checked in to CVS.

Cheers, Jeff.
Comment 3 David O'Brien 2007-10-11 14:21:03 EDT
*** Bug 327291 has been marked as a duplicate of this bug. ***
Comment 4 Chester Cheng 2007-10-28 09:44:28 EDT
Status report: translation of the 9 languages in BNE are done.  For Pune, ETA no
later than Friday 2 November 2007.
Comment 5 Chester Cheng 2007-10-28 10:23:52 EDT
(Forgot to mention that the missing language in Brisbane is Russian.  Yulia is
on holiday.)

Hi Ankit,

Could you put this into Pune's schedule?  The translation of Boilerplate.po is
*not* needed to avoid legal disputes.

Cheers,
Chester
Comment 6 Ankit Patel 2007-11-06 09:10:31 EST
Hi,

All indic (+sinhala) languages are complete now...
Comment 7 Ankit Patel 2007-11-06 09:11:47 EST
Reassigning this bug to the package owner as translation task is over now...
Comment 8 Jeff Fearn 2007-11-07 17:20:49 EST
Fixed in version 0.24

Note You need to log in before you can comment on or make changes to this bug.