Bug 32299 - Line-wrap in diagnostic-output
Line-wrap in diagnostic-output
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 15:40 EST by Enrico Scholz
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 09:28:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2001-03-19 15:40:05 EST
By default, g++ assumes -fmessage-length=72. I think this is not a good
idea because:

1. It breaks existing tools. E.g. emacs awaits a "<location>:<line>
<error-msg>" format and gets confused by the current behavior

2. It makes error-messages completely unreadable. E.g. if there are
messages saying something about templates, it's not unusual that the
template-parameter-list is splitted over several lines.

3. The value of 72 is IMHO obsoleted. Are there still existing C++
programmers  which are writing code on an 80-column console? I think most
ones are using xterms or framebuffer-screens with 100 or more columns.

4. Only the g++ frontend defaults to this linebreak. This is
inconsequentlally.
Comment 1 Enrico Scholz 2001-07-11 17:52:12 EDT
Reported upstream (http://gcc.gnu.org/cgi-bin/gnatsweb.pl?cmd=view&pr=3653)
Comment 2 Alan Cox 2002-12-15 09:28:11 EST
Rejected upstream 

Note You need to log in before you can comment on or make changes to this bug.