Bug 323041 - Fonts blurred on ThinkPad R61 [includes patch]
Fonts blurred on ThinkPad R61 [includes patch]
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 07:42 EDT by Jakub Hrozek
Modified: 2008-01-16 06:01 EST (History)
2 users (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 06:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patched driver (868.99 KB, application/x-tgz)
2007-10-08 07:42 EDT, Jakub Hrozek
no flags Details
xorg.conf (995 bytes, text/plain)
2007-10-08 07:43 EDT, Jakub Hrozek
no flags Details
xorg log (41.91 KB, text/plain)
2007-10-08 07:44 EDT, Jakub Hrozek
no flags Details

  None (edit)
Description Jakub Hrozek 2007-10-08 07:42:27 EDT
Description of problem:
After default install of F7 on my R61, the fonts were unusually blurred. After 
some googling, I've come around a workaround that includes patching 
xorg-drv-i810. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.0.0-4.fc7

How reproducible:
always

Steps to Reproduce:
Well, you have to have the hardware. Mine is Intel X3100, details can be seen 
from the Xorg.log
1. install F7
2. open your eyes
3. eeek, blurred fonts
  
Actual results:
blurred fonts

Expected results:
sharp fonts

Additional info:
Frankly speaking, I have *no* idea about the nature of the patch. But it 
worked for me, so I'm attaching it in case it could be accepted and this 
problem solved.
Comment 1 Jakub Hrozek 2007-10-08 07:42:28 EDT
Created attachment 219671 [details]
the patched driver
Comment 2 Jakub Hrozek 2007-10-08 07:43:20 EDT
Created attachment 219681 [details]
xorg.conf
Comment 3 Jakub Hrozek 2007-10-08 07:44:33 EDT
Created attachment 219691 [details]
xorg log
Comment 4 Jesse Barnes 2008-01-10 18:25:26 EST
This is probably the panel fitting bug.  The driver used to unconditionally 
set the panel fitting register, which would cause blurriness on some chips, 
even if the display was in its native mode.  Please retest with the latest 
bits and close since it should be fixed now.
Comment 5 Jakub Hrozek 2008-01-11 03:35:29 EST
Thanks, I'll try installing some recent version over the weekend and will 
reply here, then
Comment 6 Jakub Hrozek 2008-01-16 06:01:56 EST
I tried F8 Live CD and everything seems fine, closing. Thanks for poking me, 
Jesse!

Note You need to log in before you can comment on or make changes to this bug.