Bug 323131 - Unable to set keybindings with more than two modifier keys
Unable to set keybindings with more than two modifier keys
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 10:23 EDT by Russell Harrison
Modified: 2008-10-10 05:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 05:40:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2007-10-08 10:23:16 EDT
Description of problem:

When I open System --> Preferences --> Personal --> Keyboard Shortcuts I am
unable to set the open terminal shortcut to <Control><Alt><Shift>x  I can only
have two modifier keys in the setting.

I have also confirmed that I changing the
/apps/metacity/global_keybindings/run_command_terminal key in gconf also does
not work when set to <Control><Alt><Shift>x.  Setting the key to <Control><Alt>x
does work however.

This has been my standard keybinding for years and I would like to be able to
set my keys as I'm used to.

Version-Release number of selected component (if applicable):
metacity-2.20.0-1.fc8
Comment 1 Matthias Clasen 2007-10-09 00:16:13 EDT
Doesn't happen here. 
Comment 2 Bastien Nocera 2007-10-09 10:48:45 EDT
<Control><Alt><Shift>x probably wouldn't exist, it should be <Control><Alt>X, no?
Comment 3 Russell Harrison 2007-10-09 14:58:54 EDT
No I want <Control><Alt><Shift>x I've been using it for years now.  The values
in gconf actually spell out <Shift> in older versions of metacity.  Also I'm
unable to capture the key strokes in the keyboard shortcuts interface.
Comment 4 Russell Harrison 2008-04-26 10:17:25 EDT
This seems to be working properly in rawhide.
Comment 5 Bastien Nocera 2008-10-10 05:40:10 EDT
Cool, closing then. Thanks.

Note You need to log in before you can comment on or make changes to this bug.