Bug 323431 - [RHEL5.2]: Xen 3.1.1 ia64 PCI front/back fixes
[RHEL5.2]: Xen 3.1.1 ia64 PCI front/back fixes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Chris Lalancette
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 13:38 EDT by Chris Lalancette
Modified: 2010-07-19 09:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 10:12:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2007-10-08 13:38:23 EDT
Description of problem:
Xen 3.1.1 includes a number of patches to fix up PCI front/back handling,
especially for ia64.  These changesets are: 15083 and 15392.  They are a little
bit scary in that they add a whole new "controller" to ia64.  We can add the
controller, but I'm not sure if we can enable it in the config since it might
break kABI.  Kei, can you take a look and give us your thoughts on it?
Comment 1 Tetsu Yamamoto 2007-10-09 17:08:45 EDT
Cset15083 is just to initializing the variable, so it does not break kABI.  As 
for cset15392, we are now trying to check on PRIMEQUEST/Tiger4 that it does 
not break kABI.
Comment 2 Tetsu Yamamoto 2007-10-15 11:15:15 EDT
Fujitsu Xen team in Japan has tested cset 15392 with a driver domain, and 
confiremd that it has no problem and works fine. 
Comment 3 RHEL Product and Program Management 2008-02-01 17:40:08 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Bill Burns 2008-04-30 09:05:09 EDT
Where are we with these? Did they make RHEL 5.2? Or are they desired for 5.3?
Comment 5 Tetsu Yamamoto 2008-04-30 11:16:52 EDT
These are not in 5.2, so desired for 5.3.
Comment 8 Chris Lalancette 2010-07-19 09:48:37 EDT
Clearing out old flags for reporting purposes.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.