Bug 323691 - kernel-2.6.22.9-91.fc7.i686 fails to load b43 driver for BCM4309
kernel-2.6.22.9-91.fc7.i686 fails to load b43 driver for BCM4309
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 16:17 EDT by Ryan Daly
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-17 21:46:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan Daly 2007-10-08 16:17:16 EDT
Description of problem:
I'm seeing an issue w/ my wireless card not functioning properly.

I'm using the following card:
02:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 03)

I had been using ndiswrapper, but the last kernel to function properly w/ that
was kernel-2.6.22.1-41.fc7.  In subsequent kernels, the interface would load,
the link became ready, but no traffic would flow.

Since ndiswrapper is giving me issues, I decided to give b43 a try.  With
kernel-2.6.22.9-91.fc7.i686, I get the following error:
Oct  5 00:17:34 riddler kernel: b43-phy2: Broadcom 4306 WLAN found
Oct  5 00:17:44 riddler firmware_helper[6982]: Loading of
/lib/firmware/bcm43xx_microcode5.fw for b43 driver failed: No such file or directory
Oct  5 00:17:44 riddler kernel: b43-phy2 ERROR: Microcode
"bcm43xx_microcode5.fw" not available or load failed.
Oct  5 00:17:44 riddler kernel: b43-phy2 ERROR: You must go to
http://linuxwireless.org/en/users/Drivers/b43#devicefirmware and download the co
rrect firmware (version 4)

Apparently something is out of sync...  So after reading the bug report for Bug
289351 (https://bugzilla.redhat.com/show_bug.cgi?id=289351), I
tried kernel-2.6.23-0.222.rc9.git4.fc8.i686 (latest build from 10/06/07).  With
this kernel, I get the following:

/var/log/messages:
Oct  6 21:39:58 riddler kernel: ACPI: PCI Interrupt 0000:02:03.0[A] -> Link
[LNKB] -> GSI 5 (level, low) -> IRQ 5
Oct  6 21:39:58 riddler kernel: ssb: Sonics Silicon Backplane found on PCI
device 0000:02:03.0
Oct  6 21:39:58 riddler kernel: b43-phy3: Broadcom 4306 WLAN found

lsmod output:
b43                   130977  0 
ssb                    31061  1 b43
mac80211              133129  2 b43,rc80211_simple

lspci output:
02:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 03)
02:03.0 0280: 14e4:4324 (rev 03)

I get the following when attempting to start wpasupplicant:
: riddler 1# /etc/init.d/wpa_supplicant start
Starting wpa_supplicant: ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - [ OK ]

The link for wlan0 never becomes ready.


Version-Release number of selected component (if applicable):
kernel-2.6.22.9-91.fc7.i686


How reproducible:
Every time the native b43 driver loads.

Steps to Reproduce:
1. modprobe -a b43
Comment 1 John W. Linville 2007-10-16 13:58:06 EDT
What firmware do you have installed?  What tool did you use to extract it?
Comment 2 Ryan Daly 2007-10-17 09:31:40 EDT
I have tried two different firmware files.  One is wl_apsta-3.130.20.0.o, and
the other is broadcom-wl-4.80.53.0.tar.bz2 which contains wl_apsta.o and
wl_apsta_mimo.o.

MD5SUMs follow:
9207bc565c2fc9fa1591f6c7911d3fc0  wl_apsta.o
722e2e0d8cc04b8f118bb5afe6829ff9  wl_apsta_mimo.o
e08665c5c5b66beb9c3b2dd54aa80cb3  wl_apsta-3.130.20.0.o

The tool I used b43-fwcutter-008-1.fc7.  The rpm was installed as part of an
update released to FC7.
Comment 3 John W. Linville 2007-10-17 09:56:57 EDT
The fc7 kernels still require firmware extracted with the 
older "bcm43xx-fwcutter" tool.  I suggest this:

   yum install bcm43xx-fwcutter
   bcm43xx-fwcutter -w /lib/firmware wl_apsta.o
   modprobe -r b43 ; modprobe b43

Does that improve the situation when using kernel-2.6.22.9-91.fc7?
Comment 4 Ryan Daly 2007-10-17 10:37:17 EDT
Yes, it does load the b43 module now.

Oct 17 10:26:33 riddler kernel: ACPI: PCI interrupt for device 0000:02:03.0 disabled
Oct 17 10:26:33 riddler kernel: ACPI: PCI Interrupt 0000:02:03.0[A] -> Link
[LNKB] -> GSI 5 (level, low) -> IRQ 5
Oct 17 10:26:33 riddler kernel: ssb: Sonics Silicon Backplane found on PCI
device 0000:02:03.0
Oct 17 10:26:33 riddler kernel: b43-phy3: Broadcom 4306 WLAN found
Oct 17 10:26:35 riddler kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready

But, the link never becomes ready.  Not sure if the following relates or not:

: riddler 15#; /etc/init.d/wpa_supplicant restart
Stopping wpa_supplicant:                                   [  OK  ]
Starting wpa_supplicant: ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 -                              [  OK  ]

The link does not become ready after issuing a wpa_supplicant restart.
Comment 5 John W. Linville 2007-10-22 17:07:36 EDT
What sort of network are you you using?  Can you post your 
wpa_supplicant.conf?

Can you connect to an open or WEP network?  Without either wpa_supplicant or 
NetworkManager?

Alternatively, can you try _not_ starting wpa_supplicant and using 
NetworkManager instead?
Comment 6 Ryan Daly 2007-10-23 09:54:40 EDT
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=2
eapol_version=1
update_config=1
fast_reauth=1

network={
        ssid="myssid1"
        psk="My preshared key."
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=TKIP
        group=TKIP WEP104 WEP40
        disabled=0
}

network={
        ssid="myssid2"
        key_mgmt=WPA-EAP
        pairwise=CCMP
        identity="myID"
        password="myPASSWORD"
        phase1="fast_provisioning=1"
        disabled=1
}

I'll have to see if wpa_supplicant errors on startup with a WEP only
configuration.  I'll post my findings.

I do not use Gnome (I use FVWM) so I do not have access to the NetworkManager
applet.  Is wpa_supplicant going to be replaced by NetworkManager in the future,
or will this utility continue to be supported?
Comment 7 Ryan Daly 2007-11-17 02:30:41 EST
- UPDATE -

I recently installed FC8.  The b43 driver loads without issue.

Also recently started to use KDE.  I started NetworkManager and subsequently
started nm-applet.  I was able to connect to my home network using WPA
pre-shared key.

wpa_supplicant is still broken.  Is this utility going away?
Comment 8 John W. Linville 2007-11-17 21:46:58 EST
Actually, NetworkManager uses wpa_supplicant under the covers.  If 
wpa_supplicant isn't working for you, it is almost assuredly a configuration 
issue.

Since things are working for you now, I'll close this as CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.