Bug 323711 - Add ccs_lookup_nodename function from libccs in HEAD to RHEL5 libccs
Add ccs_lookup_nodename function from libccs in HEAD to RHEL5 libccs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan McCabe
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 16:27 EDT by Ryan McCabe
Modified: 2009-04-16 18:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:58:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new function (5.89 KB, patch)
2007-10-08 16:27 EDT, Ryan McCabe
no flags Details | Diff

  None (edit)
Description Ryan McCabe 2007-10-08 16:27:46 EDT
As it stands now, just about all of the command-line tools are unable to cope
with commands that specify node names that don't exactly match the names given
in /etc/cluster/cluster.conf (e.g., a bug in conga was found recently because it
was calling 'fence_node tng-3.lab.msp.redhat.com' instead of 'fence_node
tng-3'). The same problem exists if you use an IP address instead of a hostname.

Add this function to give applications a way to lookup the name that ought to be
used when given a valid address of a cluster node that doesn't exactly match the
string in the cluster.conf.


* ccs_lookup_nodename
* @cd: ccs descriptor
* @nodename: node name string
* @retval: pointer to location to assign the result, if found
*
* This function takes any valid representation (FQDN, non-qualified
* hostname, IP address, IPv6 address) of a node's name and finds its
* canonical name (per cluster.conf). This function will find the primary
* node name if passed a node's "altname" or any valid representation
* of it.
*
* Returns: 0 on success, < 0 on failure
Comment 1 Ryan McCabe 2007-10-08 16:27:46 EDT
Created attachment 220131 [details]
new function
Comment 2 RHEL Product and Program Management 2007-10-15 23:35:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 errata-xmlrpc 2008-05-21 11:58:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.