Bug 323941 - Add EUS data support to content management tools
Add EUS data support to content management tools
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
low Severity low
: ---
: ---
Assigned To: Bryan Kearney
Mike Orazi
:
Depends On:
Blocks: 253918
  Show dependency treegraph
 
Reported: 2007-10-08 18:00 EDT by James Bowes
Modified: 2013-01-10 04:55 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 09:36:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2007-10-08 18:00:23 EDT
the content management tools need to be able to populate the new eus related fields
Comment 1 James Bowes 2007-10-10 17:05:42 EDT
Added new fields accepted in the csv, is_eus, and is_default, for the matching
rhnDistChannelMap columns.
Comment 2 James Bowes 2007-10-18 13:25:38 EDT
test plan:
* ensure that you can create a channel without the two new columns
* ensure that you can create a channel with is_eus and is_default both set to Y,
  and that this channel is the default selected when registeristering a system 
  with rhn_register to an eus entitled account (see bug 323941)
* ensure that if is_eus is Y and is_default is N that the channel is selectable in 
  rhn_register, but is not the default selected.
Comment 3 Bret McMillan 2007-11-06 22:35:21 EST
version of the content mgmt tools rpm that provides this functionality?
Comment 4 James Bowes 2007-11-08 13:27:47 EST
0.4.0
Comment 5 Amy Owens 2007-12-07 11:47:32 EST
ao 12/7/07--- Can test only in qa-- moving to release pending
tested the negative test case of not having those columns with a csv I
created--- got this message:
[aowens@aowens ~]$ rhn-manage-channel-internal --server qa
--csv=/home/aowens/test.csv --create
Red Hat Network username: rhn-noc
Red Hat Network password: 
Creating channel Amy QA testing
  Channel Amy QA testing membership updated

Error Message:
    is_eus must be one of Y or N
Error Class Code: 23
Error Class Info: Could not update database entry.
** which is correct.
** testing getting the EUS choice is not valid anymore since you are not given
that choice due to the other defect-- I tested that you skip that choice
** positive case was tested in that this is how they got into qa in the first place

Note You need to log in before you can comment on or make changes to this bug.