Bug 32398 - FIXME: Cannot create a new product without any components
Summary: FIXME: Cannot create a new product without any components
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 2.8
Hardware: i386
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-20 15:29 UTC by David Lawrence
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 15:29:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Lawrence 2001-03-20 15:29:35 UTC
When creating a new product, you cannot got back to the query page and add
components to the new product because the query page breaks with an error
message.

Software error:
Can't use string ("") as an ARRAY ref while "strict refs" in use at
globals.pl line 502.

Need to figure out a way to add a component to a product with out
components.

One possibility is to have GenerateVersionTable to skip component lists
that do not have one or more components from the versioncache file.

Comment 1 David Lawrence 2001-03-20 16:28:20 UTC
Commented out the following code and it seems to have fixed the problem. For
some reason they had it where if the array was empty it would create the
variable as a scalar. Well this breaks in enter_bug.cgi and query.cgi because it
expects it to be a array reference.

#    foreach my $i (@list) {
#        if (!defined $::components{$i}) {
#            $::components{$i} = "";
#        }
#    }




Note You need to log in before you can comment on or make changes to this bug.