Bug 32399 - StarOffice 5.2 crashes on install
StarOffice 5.2 crashes on install
Status: CLOSED DUPLICATE of bug 31879
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-20 10:43 EST by bcling
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 01:18:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bcling 2001-03-20 10:43:42 EST
Can't get StarOffice 5.2 to go past the initial splash screen showing that
the installer is loading.  System completely locks up, requiring manual
power off.

Reproducible: Always
Steps to Reproduce:
1. Custom/Everything install of 7.0.91
2. Install StarOffice 5.2
3. System locks up in a few seconds after the StarOffice splash screen
appears.

Actual Results:  System freezes...

Expected Results:  Should install as on 7.0.  Don't have a 7.0.90 system
any more - I can't remember if I had this problem then or not.

Tested on two systems: PIII/800 and PII/400
Comment 1 Glen Foster 2001-03-20 12:40:53 EST
I am able to reproduce the problem here in our test-lab with Wolverine CDs.  I
believe this is already fixed (I was able to do it 3 days ago); I am currenrtly
trying a full install with today's internal tree (close to what is recently
available in rawhide) to see if the problem is "still" fixed.  I'll report my
results when I'm finished.
Comment 2 Glen Foster 2001-03-20 13:48:10 EST
Bad news: the hang still reproduces on the test-lab system. :-(

Hmmm... I get a successful installation on the test system next to my desk
(running 2-day-old kernel and XFree86) and StarOffice works fine, even with
extra-large spreadsheets.  However, I can reproduce the same hard-lock behavior
with Wolverine and today's test-tree on a test system in the lab.

The test system next to my desk has a Mach64-based video chipset.  I'll see if
we can get success on a different Mach-64-based controller to verify.

Here's some diagnostic stuff from the machine in the lab [the one that HANGS]
(IBM IntelliStation with 933MHz P-III + 128MB RAM):

# rpm -q XFree86
XFree86-4.0.3-1
# rpm -q kernel
kernel-2.4.2-0.1.31
# uname -a
Linux test117.test.redhat.com 2.4.2-0.1.31 #1 Mon Mar 19 20:30:46 EST 2001 i686
unknown
# lspci00:00.0 Host bridge: VIA Technologies, Inc. VT82C691 [Apollo PRO] (rev
c4)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x
AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev
22)00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev
30)00:07.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio
Controller (rev 20)
00:09.0 SCSI storage controller: Adaptec 7892A (rev 02)
00:0d.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
01:00.0 VGA compatible controller: S3 Inc. Savage 4 (rev 04)
# lspci -v
00:00.0 Host bridge: VIA Technologies, Inc. VT82C691 [Apollo PRO] (rev c4)
	Flags: bus master, medium devsel, latency 0
	Memory at d8000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [a0] AGP version 2.0
	Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x
AGP] (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	Memory behind bridge: dc000000-ddffffff
	Prefetchable memory behind bridge: d0000000-d7ffffff
	Capabilities: [80] Power Management version 2

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev
22)	Subsystem: VIA Technologies, Inc. VT82C686/A PCI to ISA Bridge
	Flags: bus master, stepping, medium devsel, latency 0

00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10) (prog-if
8a [Master SecP PriP])
	Subsystem: VIA Technologies, Inc. Bus Master IDE
	Flags: bus master, medium devsel, latency 32
	I/O ports at d000 [size=16]
	Capabilities: [c0] Power Management version 2

00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10) (prog-if 00
[UHCI])
	Subsystem: Unknown device 0925:1234
	Flags: bus master, medium devsel, latency 32, IRQ 9
	I/O ports at d400 [size=32]
	Capabilities: [80] Power Management version 2

00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10) (prog-if 00
[UHCI])
	Subsystem: Unknown device 0925:1234
	Flags: bus master, medium devsel, latency 32, IRQ 9
	I/O ports at d800 [size=32]
	Capabilities: [80] Power Management version 2

00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev
30)	Flags: medium devsel, IRQ 11
	Capabilities: [68] Power Management version 2

00:07.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio
Controller (rev 20)
	Subsystem: VIA Technologies, Inc.: Unknown device 4511
	Flags: medium devsel, IRQ 5
	I/O ports at dc00 [size=256]
	I/O ports at e000 [size=4]
	I/O ports at e400 [size=4]
	Capabilities: [c0] Power Management version 2

00:09.0 SCSI storage controller: Adaptec 7892A (rev 02)
	Subsystem: Adaptec: Unknown device e220
	Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 11
	BIST result: 00
	I/O ports at e800 [size=256]
	Memory at df101000 (64-bit, non-prefetchable) [size=4K]
	Expansion ROM at <unassigned> [disabled] [size=128K]
	Capabilities: [dc] Power Management version 2

00:0d.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
	Subsystem: Intel Corporation 82559 Fast Ethernet LAN on Motherboard
	Flags: bus master, medium devsel, latency 32, IRQ 11
	Memory at df100000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at ec00 [size=64]
	Memory at df000000 (32-bit, non-prefetchable) [size=1M]
	Expansion ROM at <unassigned> [disabled] [size=1M]
	Capabilities: [dc] Power Management version 2

01:00.0 VGA compatible controller: S3 Inc. Savage 4 (rev 04) (prog-if 00 [VGA])
	Subsystem: Diamond Multimedia Systems: Unknown device 4906
	Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 10
	Memory at dd000000 (32-bit, non-prefetchable) [size=512K]
	Memory at d0000000 (32-bit, prefetchable) [size=128M]
	Expansion ROM at <unassigned> [disabled] [size=64K]
	Capabilities: [dc] Power Management version 1
	Capabilities: [80] AGP version 2.0

Comment 3 Glen Foster 2001-03-20 14:05:13 EST
Once the hang occurs, keyboard input doesn't work, mouse input doesn't work,
system does not respond to ICMP echo packets (e.g., doesn't respond to ping(1)).
Comment 4 Glen Foster 2001-03-20 14:19:07 EST
Connecting a serial console to the system yields NO messages whatsoever.  Will
try installing under strace/ptrace next.
Comment 5 Glen Foster 2001-03-20 15:00:15 EST
Setting the X-display (DISPLAY=anotherhost:0) gets past the hang.
Comment 6 Derek Tattersall 2001-03-21 09:10:01 EST
Captured an strace of STar Office installer up to the point of the wedge.
The strace is on hank in /mnt/raid1/soffice.strace
Comment 7 Mike A. Harris 2001-03-21 20:22:07 EST
Just a hunch..  Can you try reproducing this with an ATI r128 or Radeon
based card?  I think this might be S3 Savage 4 related.  Also, I think it
might actually be a hardware flaw in that particular card.  I'll have to
verify this yet though..
Comment 8 Mike A. Harris 2001-03-28 01:24:29 EST
It is an S3 Savage related bug, known by the driver maintainer.
No known fix yet other than the workaround suggestion in Bug #31879

*** This bug has been marked as a duplicate of 31879 ***
Comment 9 Mike A. Harris 2001-11-02 20:11:29 EST
This bug is fixed now.  Read bug #31879 for details.

Note You need to log in before you can comment on or make changes to this bug.