Bug 32405 - Graphic Upgrade: lilo screen only contains linux, but after upgrade non RH lilo entries are preserved
Graphic Upgrade: lilo screen only contains linux, but after upgrade non RH li...
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-20 11:28 EST by Hans de Goede
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2001-03-20 11:28:41 EST
Graphical upgrade:

The lilo config screen only contains linux as boot image,
but the installer also preserves non RH lilo boot images as options,
this is not consistent.
Comment 1 Michael Fulbright 2001-03-20 14:40:36 EST
What are the additional boot options which do not show up on the graphical lilo
screen?

What does your /etc/lilo.conf look like?
Comment 2 Hans de Goede 2001-03-21 11:26:50 EST
To be clear it aren't extra options its an extra boot image (kernel image) which
doesn't show up, the win4lin one:
--- begin /etc/lilo.conf ---
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=linux

image=/boot/vmlinuz-2.2.16-22
        label=win4lin
        initrd=/boot/initrd-2.2.16-22.img
        read-only
        root=/dev/hda1

image=/boot/vmlinuz-2.4.1-0.1.9
        label=linux
        initrd=/boot/initrd-2.4.1-0.1.9.img
        read-only
        root=/dev/hda1
--- end ---

This is after an upgrade, so to be clear:
-in the installer during lilo config I only see and can only edit the linux
 boot image
-but the installer does retain the win4lin one, yet I don't see it?

Comment 3 Michael Fulbright 2001-03-21 14:08:27 EST
Brent please look into.
Comment 4 Brent Fox 2001-03-21 15:40:29 EST
We only display lilo entries that we write out.  Other changes that you may make
manually are presevered, they just aren't displayed during an upgrade.  This
isn't something we will change for the upcoming release, but I'll put this on
our list of issues to think about for future releases.  Thanks for your report.
Comment 5 Michael Fulbright 2002-03-26 12:27:06 EST
Deferred to future release.
Comment 6 Michael Fulbright 2002-05-26 14:59:48 EDT
Fixing bug status- sorry for the email.
Comment 7 Red Hat Bugzilla 2006-02-21 13:47:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.